CKAN has Unauthenticated SQL Injection and Authorization Bypass in datastore_search_sql
CVE-2026-42031GHSA-h7j7-3rx6-xvcg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckan 2.11.5, 2.10.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ckan
- Affected
- < 2.10.10>= 2.11.0, <= 2.11.4
- Fixed in
- 2.11.5, 2.10.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h7j7-3rx6-xvcg lists affected ranges: PyPI ckan >=0 =2.11.0 <2.11.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h7j7-3rx6-xvcg lists affected ranges: PyPI ckan >=0 =2.11.0 <=2.11.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-42031: 1.82% estimated exploitation activity in the next 30 days; percentile 78.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in datastoresearchsql allowed attackers to inject SQL in order to gain access to private resources and PostgreSQL system information. Patches The issue has been patched in CKAN 2.10.10 and CKAN 2.11.5 Workarounds Disable the DataStore SQL search (ckan.datastore.sqlsearch.enabled = false). Note that the SQL search is disabled by default. More information As stated in the documentation, this action function has protections that offer some safety but are not designed to prevent all types of abuse. Depending on the sensitivity of private data in a project's DataStore and the likelihood of abuse of a consuming site, a developer may choose to disable this action function or restrict its use with a IAuthFunctions plugin. Credits Reported by Arvin Shivram of Brutecat Security
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h7j7-3rx6-xvcg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h7j7-3rx6-xvcg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42031 Advisory: CKAN has Unauthenticated SQL Injection and Authorization Bypass in `datastore_search_sql` IDs: CVE-2026-42031, GHSA-h7j7-3rx6-xvcg Record: https://patchnext.com/advisories/cve-2026-42031 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckan 2.11.5, 2.10.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ckan: affected < 2.10.10; >= 2.11.0, <= 2.11.4; fixed in 2.11.5, 2.10.10 ## Suggested inspection (read-only) - `python -m pip show ckan`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckan. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h7j7-3rx6-xvcg (OSV record GHSA-h7j7-3rx6-xvcg lists affected ranges: PyPI ckan >=0 =2.11.0 <2.11.5 (fixed)) - Verified: https://github.com/advisories/GHSA-h7j7-3rx6-xvcg (GitHub-reviewed advisory GHSA-h7j7-3rx6-xvcg lists affected ranges: PyPI ckan >=0 =2.11.0 <=2.11.4) Commands are suggestions: review each one before running it.
Loading voting…