Skip to content

← Actionable
Low, CVSS 2.3amended

OpenClaw: Assistant media route missed scope enforcement for trusted-proxy authorization

CVE-2026-41908GHSA-v8qf-fr4g-28p2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.4.20
    Fixed in
    2026.4.20

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41908: 0.22% estimated exploitation activity in the next 30 days; percentile 12.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected Packages / Versions - Package: openclaw (npm) - Affected versions: < 2026.4.20 - Patched version: 2026.4.20 Impact The Control UI assistant-media route authenticated trusted-proxy callers but did not enforce the declared operator scopes for identity-bearing HTTP auth paths. A trusted-proxy caller without operator.read could access assistant-media files and metadata that were otherwise inside allowed media roots. The route still required successful gateway authentication and media-root checks. Severity is low. Fix Assistant-media file and metadata requests now require operator.read on identity-bearing HTTP auth paths. Fix commit: - 99ef3a63c58440d53f8e45ad861b846032fcb036 Release Fixed in OpenClaw 2026.4.20.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v8qf-fr4g-28p2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v8qf-fr4g-28p2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41908

Advisory: OpenClaw: Assistant media route missed scope enforcement for trusted-proxy authorization
IDs: CVE-2026-41908, GHSA-v8qf-fr4g-28p2
Record: https://patchnext.com/advisories/cve-2026-41908 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.4.20; fixed in 2026.4.20

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v8qf-fr4g-28p2 (OSV record GHSA-v8qf-fr4g-28p2 lists affected ranges: npm openclaw >=0 <2026.4.20 (fixed))
- Verified: https://github.com/advisories/GHSA-v8qf-fr4g-28p2 (GitHub-reviewed advisory GHSA-v8qf-fr4g-28p2 lists affected ranges: npm openclaw >=0 <2026.4.20)

Commands are suggestions: review each one before running it.

Loading voting…