Skip to content

← Actionable
Medium, CVSS 6.3amended

uuid: Missing buffer bounds check in v3/v5/v6 when buf is provided

CVE-2026-41907GHSA-w5hq-g745-h8pq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uuid 13.0.1, 12.0.1, 11.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm uuid

    Affected
    >= 12.0.0, < 12.0.1>= 13.0.0, < 13.0.1< 11.1.1
    Fixed in
    13.0.1, 12.0.1, 11.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41907: 0.35% estimated exploitation activity in the next 30 days; percentile 28.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-41988: 0.18% estimated exploitation activity in the next 30 days; percentile 7.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The v3(), v5(), and v6() API methods (not uuid release versions) accept external output buffers but do not reject out-of-range writes (small buf or large offset). By contrast, v4(), v1(), and v7() API methods explicitly throw RangeError on invalid bounds. This inconsistency allows silent partial writes into caller-provided buffers. Affected code - src/v35.ts (v3()/v5() path) writes buf[offset + i] without bounds validation. - src/v6.ts writes buf[offset + i] without bounds validation. Reproducible PoC Observed: - v4() THREW RangeError - v5() NOTHROW - v6() NOTHROW Example partial overwrite evidence captured during audit: Security impact - Primary: integrity/robustness issue (silent partial output). - If an application assumes full UUID writes into preallocated buffers, this can produce malformed/truncated/partially stale identifiers without error. - In systems where caller-controlled offsets/buffer sizes are exposed indirectly, this may become a security-relevant logic flaw.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w5hq-g745-h8pq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w5hq-g745-h8pq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41907

Advisory: uuid: Missing buffer bounds check in v3/v5/v6 when buf is provided
IDs: CVE-2026-41907, GHSA-w5hq-g745-h8pq
Record: https://patchnext.com/advisories/cve-2026-41907 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uuid 13.0.1, 12.0.1, 11.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm uuid: affected >= 12.0.0, < 12.0.1; >= 13.0.0, < 13.0.1; < 11.1.1; fixed in 13.0.1, 12.0.1, 11.1.1

## Suggested inspection (read-only)
- `npm ls uuid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uuid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w5hq-g745-h8pq (OSV record GHSA-w5hq-g745-h8pq lists affected ranges: npm uuid >=0 =12.0.0 =13.0.0 <13.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-w5hq-g745-h8pq (GitHub-reviewed advisory GHSA-w5hq-g745-h8pq lists affected ranges: npm uuid >=12.0.0 =13.0.0 =0 <11.1.1)

Commands are suggestions: review each one before running it.

Loading voting…