Skip to content

← Actionable
High, CVSS 8.3

rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer

CVE-2026-41898GHSA-hppc-g8h3-xhp3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl 0.10.78), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io openssl

    Affected
    >= 0.9.24, < 0.10.78
    Fixed in
    0.10.78

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41898: 0.28% estimated exploitation activity in the next 30 days; percentile 20.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The FFI trampolines behind SslContextBuilder::setpskclientcallback, setpskservercallback, setcookiegeneratecb, and setstatelesscookiegeneratecb forwarded the user closure's returned usize directly to OpenSSL without checking it against the &mut [u8] that was handed to the closure. This can lead to buffer overflows and other unintended consequences.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hppc-g8h3-xhp3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41898

Advisory: rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer
IDs: CVE-2026-41898, GHSA-hppc-g8h3-xhp3
Record: https://patchnext.com/advisories/cve-2026-41898 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl 0.10.78. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io openssl: affected >= 0.9.24, < 0.10.78; fixed in 0.10.78

## Suggested inspection (read-only)
- crates.io openssl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hppc-g8h3-xhp3 (GitHub-reviewed advisory GHSA-hppc-g8h3-xhp3 lists affected ranges: crates.io openssl >=0.9.24 <0.10.78)

Commands are suggestions: review each one before running it.

Loading voting…