Skip to content

← Actionable
Medium, CVSS 5.3

MantisBT is Vulnerable to Reflected XSS in Rendering Dynamic Custom Textarea Field

CVE-2026-41897GHSA-j7v9-f46r-2rp4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.28.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41897: 0.28% estimated exploitation activity in the next 30 days; percentile 20.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Lack of validation of filtertarget parameter on returndynamicfilters.php (normally used as an AJAX in View Issues Page) allows an attacker to inject arbitrary HTML if the target is a TEXTAREA custom field. Impact Cross-site scripting (XSS) Patches - c885af13f0b8596714ffe11df757c09f35fbd8f4 Workarounds None Credits Thanks to siunam (Tang Cheuk Hei) for discovering and responsibly reporting the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j7v9-f46r-2rp4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41897

Advisory: MantisBT is Vulnerable to Reflected XSS in Rendering Dynamic Custom Textarea Field
IDs: CVE-2026-41897, GHSA-j7v9-f46r-2rp4
Record: https://patchnext.com/advisories/cve-2026-41897 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.28.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mantisbt/mantisbt: affected >= 1.0.0, < 2.28.2; fixed in 2.28.2

## Suggested inspection (read-only)
- Packagist mantisbt/mantisbt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mantisbt/mantisbt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j7v9-f46r-2rp4 (GitHub-reviewed advisory GHSA-j7v9-f46r-2rp4 lists affected ranges: Packagist mantisbt/mantisbt >=1.0.0 <2.28.2)

Commands are suggestions: review each one before running it.

Loading voting…