Skip to content

← Actionable
Medium, CVSS 5.3

CI4MS has a Deactivated User Session Bypass (active=0)

CVE-2026-41891GHSA-5hfv-c864-qcq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.31.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41891: 0.27% estimated exploitation activity in the next 30 days; percentile 19.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The auth filter has the deactivated/banned user check commented out. Details CodeIgniter Shield's loggedIn() re-checks the status field (catching status='banned'), but does not re-check the active field for existing sessions. When an admin deactivates a user (active=0) after they have already logged in: - Their session cookie remains valid - auth()-loggedIn() still returns true - The commented-out code is the only mechanism that would have checked !$user-active Evidence <img width="981" height="654" alt="image" src="https://github.com/user-attachments/assets/6f75d144-5bcf-4a3f-bc35-bb0715c3ed05" / Impact - User deactivation does NOT immediately revoke backend access - Deactivated user retains full access until session expires (default: 7200s) Additional note The commented-out block appears to be a deferred placeholder — it was written but disabled from the very first commit that introduced the filter, and has never been active. The later addition of SessionTracker (v0.31.4.0)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5hfv-c864-qcq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41891

Advisory: CI4MS has a Deactivated User Session Bypass (active=0)
IDs: CVE-2026-41891, GHSA-5hfv-c864-qcq9
Record: https://patchnext.com/advisories/cve-2026-41891 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.31.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ci4-cms-erp/ci4ms: affected >= 0.26.0, <= 0.31.7.0; fixed in 0.31.8.0

## Suggested inspection (read-only)
- Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ci4-cms-erp/ci4ms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5hfv-c864-qcq9 (GitHub-reviewed advisory GHSA-5hfv-c864-qcq9 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0.26.0 <=0.31.7.0)

Commands are suggestions: review each one before running it.

Loading voting…