Skip to content

← Actionable
Low, CVSS 2.3

pgx: SQL Injection via placeholder confusion with dollar quoted string literals

CVE-2026-41889GHSA-j88v-2chj-qfwx

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/jackc/pgx

    Affected
    <= 3.6.2
    Fixed in
    no fixed version recorded
  • Go github.com/jackc/pgx/v5

    Affected
    < 5.9.2
    Fixed in
    5.9.2
  • Go github.com/jackc/pgx/v4

    Affected
    <= 4.18.3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41889: 0.36% estimated exploitation activity in the next 30 days; percentile 29.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact SQL Injection can occur when: 1. The non-default simple protocol is used. 2. A dollar quoted string literal is used in the SQL query. 3. That string literal contains text that would be would be interpreted as a placeholder outside of a string literal. 4. The value of that placeholder is controllable by the attacker. e.g. This is unlikely to occur outside of a contrived scenario. Patches The problem is resolved in v5.9.2. Workarounds Do not use the simple protocol to execute queries matching all the above conditions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j88v-2chj-qfwx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41889

Advisory: pgx: SQL Injection via placeholder confusion with dollar quoted string literals
IDs: CVE-2026-41889, GHSA-j88v-2chj-qfwx
Record: https://patchnext.com/advisories/cve-2026-41889 (revision 1, source checked 26 Oct 2026, 15:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/jackc/pgx/v5 5.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/jackc/pgx: affected <= 3.6.2
- Go github.com/jackc/pgx/v5: affected < 5.9.2; fixed in 5.9.2
- Go github.com/jackc/pgx/v4: affected <= 4.18.3

## Suggested inspection (read-only)
- Go github.com/jackc/pgx: check the installed version with your package manager.
- Go github.com/jackc/pgx/v5: check the installed version with your package manager.
- Go github.com/jackc/pgx/v4: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/jackc/pgx, github.com/jackc/pgx/v5, github.com/jackc/pgx/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j88v-2chj-qfwx (GitHub-reviewed advisory GHSA-j88v-2chj-qfwx lists affected ranges: Go github.com/jackc/pgx/v5 >=0 =0 =0 <=3.6.2)

Commands are suggestions: review each one before running it.

Loading voting…