i18next-locize-backend has URL Injection via Unsanitized Path Parameters
CVE-2026-41885GHSA-mgcp-mfp8-3q45
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-locize-backend 9.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 9.0.2
- Fixed in
- 9.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mgcp-mfp8-3q45 lists affected ranges: npm i18next-locize-backend >=0 <9.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mgcp-mfp8-3q45 lists affected ranges: npm i18next-locize-backend >=0 <9.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-41885: 0.22% estimated exploitation activity in the next 30 days; percentile 13.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Versions of i18next-locize-backend prior to 9.0.2 interpolate lng, ns, projectId, and version directly into the configured loadPath / privatePath / addPath / updatePath / getLanguagesPath URL templates with no path-component validation and no encoding. When an application exposes any of these values to user-controlled input (?lng= / ?ns= query parameters via i18next-browser-languagedetector, cookies, request headers, or a URL-derived projectId), a crafted value can change the structure of the outgoing request URL. Affected call sites in lib/index.js (pre-patch): the interpolate() helper is used at the five URL-build sites — readAny/read (line 415 for private, 426 for public), getLanguages (lines 271 and 296), and writePage (lines 616 and 622) for the missing-key and update POST paths. The helper interpolate in lib/utils.js substitutes raw values with no encoding. Impact An attacker who can influence lng, ns, projectId, or version can: - Path traversal — lng = '../../admin'…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mgcp-mfp8-3q45
- Revision 1 · created ·
Published from osv record GHSA-mgcp-mfp8-3q45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41885 Advisory: i18next-locize-backend has URL Injection via Unsanitized Path Parameters IDs: CVE-2026-41885, GHSA-mgcp-mfp8-3q45 Record: https://patchnext.com/advisories/cve-2026-41885 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18next-locize-backend 9.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18next-locize-backend: affected < 9.0.2; fixed in 9.0.2 ## Suggested inspection (read-only) - `npm ls i18next-locize-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18next-locize-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mgcp-mfp8-3q45 (OSV record GHSA-mgcp-mfp8-3q45 lists affected ranges: npm i18next-locize-backend >=0 <9.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mgcp-mfp8-3q45 (GitHub-reviewed advisory GHSA-mgcp-mfp8-3q45 lists affected ranges: npm i18next-locize-backend >=0 <9.0.2) Commands are suggestions: review each one before running it.
Loading voting…