In Spring for Apache Kafka, overly broad trusted-package matching in header mappers exposes JDK classes to deserialization
CVE-2026-41731GHSA-xq69-5h5v-x9x4
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.kafka:spring-kafka
- Affected
- >= 4.0.0, <= 4.0.5>= 3.3.0, <= 3.3.15>= 3.2.0, <= 3.2.13>= 2.9.0, <= 2.9.13<= 2.8.11
- Fixed in
- 4.0.6, 3.3.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xq69-5h5v-x9x4 lists affected ranges: Maven org.springframework.kafka:spring-kafka >=4.0.0 =3.3.0 =3.2.0 =2.9.0 =0 <=2.8.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-41731: 0.51% estimated exploitation activity in the next 30 days; percentile 43.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
JsonKafkaHeaderMapper and the deprecated DefaultKafkaHeaderMapper matched type headers against trusted packages using a prefix check, meaning that trusting any package implicitly trusted all of its subpackages. Combined with Jackson's default bean deserialization, a producer could supply crafted header values that caused the consumer to deserialize arbitrary JDK types. Affected versions: Spring for Apache Kafka 4.0.0 through 4.0.5; 3.3.0 through 3.3.15; 3.2.0 through 3.2.13; 2.9.0 through 2.9.13; 2.8.0 through 2.8.11.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xq69-5h5v-x9x4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41731 Advisory: In Spring for Apache Kafka, overly broad trusted-package matching in header mappers exposes JDK classes to deserialization IDs: CVE-2026-41731, GHSA-xq69-5h5v-x9x4 Record: https://patchnext.com/advisories/cve-2026-41731 (revision 1, source checked 26 Oct 2026, 16:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.kafka:spring-kafka 4.0.6, 3.3.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.kafka:spring-kafka: affected >= 4.0.0, <= 4.0.5; >= 3.3.0, <= 3.3.15; >= 3.2.0, <= 3.2.13; >= 2.9.0, <= 2.9.13; <= 2.8.11; fixed in 4.0.6, 3.3.16 ## Suggested inspection (read-only) - Maven org.springframework.kafka:spring-kafka: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.kafka:spring-kafka. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xq69-5h5v-x9x4 (GitHub-reviewed advisory GHSA-xq69-5h5v-x9x4 lists affected ranges: Maven org.springframework.kafka:spring-kafka >=4.0.0 =3.3.0 =3.2.0 =2.9.0 =0 <=2.8.11) Commands are suggestions: review each one before running it.
Loading voting…