Spring for Apache Kafka: Improper Validation of Retry Topic Header Values Leads to Retry Sequence Manipulation
CVE-2026-41727GHSA-53w6-v7cv-fc9h
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.kafka:spring-kafka
- Affected
- >= 4.0.0, <= 4.0.5>= 3.3.0, <= 3.3.15>= 3.2.0, <= 3.2.13>= 2.9.0, <= 2.9.13<= 2.8.11
- Fixed in
- 4.0.6, 3.3.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-53w6-v7cv-fc9h lists affected ranges: Maven org.springframework.kafka:spring-kafka >=4.0.0 =3.3.0 =3.2.0 =2.9.0 =0 <=2.8.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-41727: 0.24% estimated exploitation activity in the next 30 days; percentile 15.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Kafka's retry topic infrastructure did not sufficiently validate user-controlled header values before acting on them. A producer could send a record with a crafted retrytopic-attempts header to supply an out-of-range attempt count and cause the retry topic router to misidentify where the message was in the retry sequence. Affected versions: Spring for Apache Kafka 4.0.0 through 4.0.5; 3.3.0 through 3.3.15; 3.2.0 through 3.2.13; 2.9.0 through 2.9.13; 2.8.0 through 2.8.11.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-53w6-v7cv-fc9h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41727 Advisory: Spring for Apache Kafka: Improper Validation of Retry Topic Header Values Leads to Retry Sequence Manipulation IDs: CVE-2026-41727, GHSA-53w6-v7cv-fc9h Record: https://patchnext.com/advisories/cve-2026-41727 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.kafka:spring-kafka 4.0.6, 3.3.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.kafka:spring-kafka: affected >= 4.0.0, <= 4.0.5; >= 3.3.0, <= 3.3.15; >= 3.2.0, <= 3.2.13; >= 2.9.0, <= 2.9.13; <= 2.8.11; fixed in 4.0.6, 3.3.16 ## Suggested inspection (read-only) - Maven org.springframework.kafka:spring-kafka: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.kafka:spring-kafka. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-53w6-v7cv-fc9h (GitHub-reviewed advisory GHSA-53w6-v7cv-fc9h lists affected ranges: Maven org.springframework.kafka:spring-kafka >=4.0.0 =3.3.0 =3.2.0 =2.9.0 =0 <=2.8.11) Commands are suggestions: review each one before running it.
Loading voting…