Spring Data Commons: Denial of Service via excessive memory allocation in projection binding
CVE-2026-41721GHSA-5m4m-73w9-8433
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.data:spring-data-commons
- Affected
- >= 4.0.0, <= 4.0.5>= 3.5.0, <= 3.5.11>= 3.4.0, <= 3.4.14>= 3.0.0, <= 3.3.16<= 2.7.19
- Fixed in
- 4.0.6, 3.5.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5m4m-73w9-8433 lists affected ranges: Maven org.springframework.data:spring-data-commons >=4.0.0 =3.5.0 =3.4.0 =3.0.0 =0 <=2.7.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-41721: 0.33% estimated exploitation activity in the next 30 days; percentile 26.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Data Commons contains a vulnerability that can lead to a Denial of Service (DoS) condition if Spring Data Web Support is enabled in conjunction with a Controller method using @ProjectedPayload, when an attacker sends a specially crafted HTTP request that causes the application to allocate lots of memory. Affected versions: Spring Data Commons 4.0.0 through 4.0.5; 3.5.0 through 3.5.11; 3.4.0 through 3.4.14; 3.3.0 through 3.3.16; 3.2.0 through 3.2.15; 3.1.0 through 3.1.14; 3.0.0 through 3.0.15; 2.7.0 through 2.7.19.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5m4m-73w9-8433
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41721 Advisory: Spring Data Commons: Denial of Service via excessive memory allocation in projection binding IDs: CVE-2026-41721, GHSA-5m4m-73w9-8433 Record: https://patchnext.com/advisories/cve-2026-41721 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.data:spring-data-commons 4.0.6, 3.5.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.data:spring-data-commons: affected >= 4.0.0, <= 4.0.5; >= 3.5.0, <= 3.5.11; >= 3.4.0, <= 3.4.14; >= 3.0.0, <= 3.3.16; <= 2.7.19; fixed in 4.0.6, 3.5.12 ## Suggested inspection (read-only) - Maven org.springframework.data:spring-data-commons: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.data:spring-data-commons. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5m4m-73w9-8433 (GitHub-reviewed advisory GHSA-5m4m-73w9-8433 lists affected ranges: Maven org.springframework.data:spring-data-commons >=4.0.0 =3.5.0 =3.4.0 =3.0.0 =0 <=2.7.19) Commands are suggestions: review each one before running it.
Loading voting…