Skip to content

← Actionable
High, CVSS 8.1

Spring Data MongoDB is vulnerable to SpEL (Spring Expression Language) expression injection

CVE-2026-41717GHSA-5whc-4q84-fj73

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-5whc-4q84-fj73 lists affected ranges: Maven org.springframework.data:spring-data-mongodb >=5.0.0 =4.5.0 =4.4.0 =4.0.0 =0 <=3.4.19

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41717: 0.33% estimated exploitation activity in the next 30 days; percentile 26.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring Data MongoDB contains a SpEL (Spring Expression Language) expression injection vulnerability. The issue occurs during parameter binding when a user-defined repository query method is annotated with @Query and utilizes a capture-all placeholder. Affected versions: Spring Data MongoDB 5.0.0 through 5.0.5; 4.5.0 through 4.5.11; 4.4.0 through 4.4.14; 4.3.0 through 4.3.16; 4.2.0 through 4.2.15; 4.1.0 through 4.1.14; 4.0.0 through 4.0.15; 3.4.0 through 3.4.19.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5whc-4q84-fj73

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41717

Advisory: Spring Data MongoDB is vulnerable to SpEL (Spring Expression Language) expression injection
IDs: CVE-2026-41717, GHSA-5whc-4q84-fj73
Record: https://patchnext.com/advisories/cve-2026-41717 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.springframework.data:spring-data-mongodb 5.0.6, 4.5.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.data:spring-data-mongodb: affected >= 5.0.0, <= 5.0.5; >= 4.5.0, <= 4.5.11; >= 4.4.0, <= 4.4.14; >= 4.0.0, <= 4.3.16; <= 3.4.19; fixed in 4.5.12, 5.0.6

## Suggested inspection (read-only)
- Maven org.springframework.data:spring-data-mongodb: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.data:spring-data-mongodb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5whc-4q84-fj73 (GitHub-reviewed advisory GHSA-5whc-4q84-fj73 lists affected ranges: Maven org.springframework.data:spring-data-mongodb >=5.0.0 =4.5.0 =4.4.0 =4.0.0 =0 <=3.4.19)

Commands are suggestions: review each one before running it.

Loading voting…