Skip to content

← Actionable
High, CVSS 8.2amended

i18next-fs-backend: Path traversal via unsanitised lng/ns allows arbitrary file read/overwrite

CVE-2026-41693GHSA-8847-338w-5hcj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-fs-backend 2.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-41693: 0.29% estimated exploitation activity in the next 30 days; percentile 21.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Versions of i18next-fs-backend prior to 2.6.4 interpolate the caller-supplied lng and ns values directly into the configured loadPath and addPath templates with no path-component validation and no sanitisation. When an application exposes the resolved language code to user-controlled input (?lng= query parameter, cookie, request header), a crafted value can break out of the intended locale directory. Affected call sites in lib/index.js: - read (line 38 pre-patch): const filename = interpolate(loadPath, { lng: language, ns: namespace }) - removeFile (line 101 pre-patch): same pattern against addPath - writeFile (line 127 pre-patch): same pattern against addPath for queued missing-key writes The helper interpolate in lib/utils.js substitutes raw values with no encoding — unlike the addQueryString helper in i18next-http-backend, there is no equivalent safety for path interpolation. Impact - Arbitrary file read. With a loadPath like /locales/{{lng}}/{{ns}}.json, an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8847-338w-5hcj

  2. Revision 1 · created ·

    Published from osv record GHSA-8847-338w-5hcj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41693

Advisory: i18next-fs-backend: Path traversal via unsanitised lng/ns allows arbitrary file read/overwrite
IDs: CVE-2026-41693, GHSA-8847-338w-5hcj
Record: https://patchnext.com/advisories/cve-2026-41693 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: i18next-fs-backend 2.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm i18next-fs-backend: affected < 2.6.4; fixed in 2.6.4

## Suggested inspection (read-only)
- `npm ls i18next-fs-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on i18next-fs-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8847-338w-5hcj (OSV record GHSA-8847-338w-5hcj lists affected ranges: npm i18next-fs-backend >=0 <2.6.4 (fixed))
- Verified: https://github.com/advisories/GHSA-8847-338w-5hcj (GitHub-reviewed advisory GHSA-8847-338w-5hcj lists affected ranges: npm i18next-fs-backend >=0 <2.6.4)

Commands are suggestions: review each one before running it.

Loading voting…