Skip to content

← Actionable
Medium, CVSS 4.7amended

i18nextify has DOM XSS via javascript:/data: URL schemes in translated href/src attributes

CVE-2026-41692GHSA-6457-mxpq-4fqq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18nextify 4.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-41692: 0.14% estimated exploitation activity in the next 30 days; percentile 3.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Versions of i18nextify prior to 4.0.8 substitute {{key}} interpolation tokens inside src and href attribute values with the raw string returned by i18next.t(). The substitution logic in src/localize.js (replaceInside handler around line 122) only guards against a duplicated http:// origin prefix — it does not validate the URL scheme of the substituted value. A translated value such as javascript:alert(1) or data:text/html,<script...</script is applied unchanged to the live DOM attribute. Impact When an attacker can influence the content of a translation file or the translation-backend response — compromised translation CDN, user-contributed locales, MITM on a plain-HTTP backend, write access to the translation JSON — they can: - Set any href on an anchor to a javascript: URI, executing arbitrary JavaScript when the victim clicks the link. - Set any src on <iframe, <object, or <embed to a data:text/html URI containing a full script payload that runs in the page's origin. - Use…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6457-mxpq-4fqq

  2. Revision 1 · created ·

    Published from osv record GHSA-6457-mxpq-4fqq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41692

Advisory: i18nextify has DOM XSS via javascript:/data: URL schemes in translated href/src attributes
IDs: CVE-2026-41692, GHSA-6457-mxpq-4fqq
Record: https://patchnext.com/advisories/cve-2026-41692 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: i18nextify 4.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm i18nextify: affected < 4.0.8; fixed in 4.0.8

## Suggested inspection (read-only)
- `npm ls i18nextify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on i18nextify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6457-mxpq-4fqq (OSV record GHSA-6457-mxpq-4fqq lists affected ranges: npm i18nextify >=0 <4.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-6457-mxpq-4fqq (GitHub-reviewed advisory GHSA-6457-mxpq-4fqq lists affected ranges: npm i18nextify >=0 <4.0.8)

Commands are suggestions: review each one before running it.

Loading voting…