i18next-http-backend has Path Traversal & URL Injection via Unsanitised lng/ns
CVE-2026-41691GHSA-q89c-q3h5-w34g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-http-backend 3.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.0.5
- Fixed in
- 3.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q89c-q3h5-w34g lists affected ranges: npm i18next-http-backend >=0 <3.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q89c-q3h5-w34g lists affected ranges: npm i18next-http-backend >=0 <3.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-41691: 0.31% estimated exploitation activity in the next 30 days; percentile 24.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Versions of i18next-http-backend prior to 3.0.5 interpolate the lng and ns values directly into the configured loadPath / addPath URL template without any encoding, validation, or path sanitisation. When an application exposes the language-code selection to user-controlled input (the default — i18next-browser-languagedetector reads ?lng= query params, cookies, localStorage, and request headers), an attacker can inject characters that change the structure of the outgoing request URL. Affected call sites: - readAny — lib/index.js:64: interpolate(resolvedLoadPath, { lng: languages.join('+'), ns: namespaces.join('+') }) - create — lib/index.js:123 (pre-patch): interpolate(addPath, { lng, ns: namespace }) The helper interpolate (lib/utils.js) previously returned the raw value with no encoding. In contrast, addQueryString already correctly uses encodeURIComponent for each query-string param — only the URL-path substitution was unprotected. Impact An attacker who can influence the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q89c-q3h5-w34g
- Revision 1 · created ·
Published from osv record GHSA-q89c-q3h5-w34g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41691 Advisory: i18next-http-backend has Path Traversal & URL Injection via Unsanitised lng/ns IDs: CVE-2026-41691, GHSA-q89c-q3h5-w34g Record: https://patchnext.com/advisories/cve-2026-41691 (revision 2, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18next-http-backend 3.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18next-http-backend: affected < 3.0.5; fixed in 3.0.5 ## Suggested inspection (read-only) - `npm ls i18next-http-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18next-http-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q89c-q3h5-w34g (OSV record GHSA-q89c-q3h5-w34g lists affected ranges: npm i18next-http-backend >=0 <3.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-q89c-q3h5-w34g (GitHub-reviewed advisory GHSA-q89c-q3h5-w34g lists affected ranges: npm i18next-http-backend >=0 <3.0.5) Commands are suggestions: review each one before running it.
Loading voting…