Skip to content

← Actionable
Medium, CVSS 4.8amended

Claude SDK for TypeScript has Insecure Default File Permissions in Local Filesystem Memory Tool

CVE-2026-41686GHSA-p7fg-763f-g4gf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/sdk 0.91.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41686: 0.12% estimated exploitation activity in the next 30 days; percentile 1.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The BetaLocalFilesystemMemoryTool in the Anthropic TypeScript SDK created memory files and directories using the Node.js default modes (0o666 for files, 0o777 for directories), leaving them world-readable on systems with a standard umask and world-writable in environments with a permissive umask such as many Docker base images. A local attacker on a shared host could read persisted agent state, and in containerized deployments could modify memory files to influence subsequent model behavior. Users on the affected versions are advised to update to the latest version. Claude SDK thanks lucasfutures for the report.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p7fg-763f-g4gf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p7fg-763f-g4gf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41686

Advisory: Claude SDK for TypeScript has Insecure Default File Permissions in Local Filesystem Memory Tool
IDs: CVE-2026-41686, GHSA-p7fg-763f-g4gf
Record: https://patchnext.com/advisories/cve-2026-41686 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/sdk 0.91.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @anthropic-ai/sdk: affected >= 0.79.0, < 0.91.1; fixed in 0.91.1

## Suggested inspection (read-only)
- `npm ls @anthropic-ai/sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @anthropic-ai/sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p7fg-763f-g4gf (OSV record GHSA-p7fg-763f-g4gf lists affected ranges: npm @anthropic-ai/sdk >=0.79.0 <0.91.1 (fixed))
- Verified: https://github.com/advisories/GHSA-p7fg-763f-g4gf (GitHub-reviewed advisory GHSA-p7fg-763f-g4gf lists affected ranges: npm @anthropic-ai/sdk >=0.79.0 <0.91.1)

Commands are suggestions: review each one before running it.

Loading voting…