i18next-http-middleware: HTTP response splitting and DoS via unsanitised Content-Language header
CVE-2026-41683GHSA-c3h8-g69v-pjrg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-http-middleware 3.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.9.3
- Fixed in
- 3.9.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c3h8-g69v-pjrg lists affected ranges: npm i18next-http-middleware >=0 <3.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c3h8-g69v-pjrg lists affected ranges: npm i18next-http-middleware >=0 <3.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-41683: 0.33% estimated exploitation activity in the next 30 days; percentile 25.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Versions of i18next-http-middleware prior to 3.9.3 wrote user-controlled language values into the Content-Language response header after passing them through utils.escape(), which is an HTML-entity encoder that does not strip carriage return, line feed, or other control characters. When the application used an older i18next (< 19.5.0) that still exercised the backward-compatibility fallback at LanguageDetector.js:100 or otherwise produced a raw detected value, CRLF sequences in the attacker-controlled lng parameter reached res.setHeader('Content-Language', ...) verbatim. Impact Two concrete outcomes depending on the Node.js version: - Node.js < 14.6.0 — HTTP response splitting. An attacker crafting a request like GET /?lng=en%0d%0aX-Injected%3A+malicious could inject arbitrary additional HTTP response headers, enabling: - Session fixation via an injected Set-Cookie - Cache poisoning (injecting Location, Content-Type, etc.) - Reflected XSS in controlled response bodies -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c3h8-g69v-pjrg
- Revision 1 · created ·
Published from osv record GHSA-c3h8-g69v-pjrg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41683 Advisory: i18next-http-middleware: HTTP response splitting and DoS via unsanitised Content-Language header IDs: CVE-2026-41683, GHSA-c3h8-g69v-pjrg Record: https://patchnext.com/advisories/cve-2026-41683 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18next-http-middleware 3.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18next-http-middleware: affected < 3.9.3; fixed in 3.9.3 ## Suggested inspection (read-only) - `npm ls i18next-http-middleware --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18next-http-middleware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c3h8-g69v-pjrg (OSV record GHSA-c3h8-g69v-pjrg lists affected ranges: npm i18next-http-middleware >=0 <3.9.3 (fixed)) - Verified: https://github.com/advisories/GHSA-c3h8-g69v-pjrg (GitHub-reviewed advisory GHSA-c3h8-g69v-pjrg lists affected ranges: npm i18next-http-middleware >=0 <3.9.3) Commands are suggestions: review each one before running it.
Loading voting…