Skip to content

← Actionable
Critical, CVSS 10.0amended

paperclip Vulnerable to Unauthenticated Remote Code Execution via Import Authorization Bypass

CVE-2026-41679GHSA-68qg-g8mg-6pr7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (paperclipai 2026.410.0; @paperclipai/server 2026.410.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-41679: 31.67% estimated exploitation activity in the next 30 days; percentile 98.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated attacker can achieve full remote code execution on any network-accessible Paperclip instance running in authenticated mode with default configuration. No user interaction, no credentials, just the target's address. The entire chain is six API calls. I verified every step against the latest version. I have a fully automated PoC script and a video recording available. Discord: sagi03581 Steps to Reproduce The attack chains four independent flaws to escalate from zero access to RCE: Step 1: Create an account (no invite, no email verification) Returns a valid account immediately. No invite token required, no email verification. This works because PAPERCLIPAUTHDISABLESIGNUP defaults to false in server/src/config.ts:169-173: And email verification is hardcoded off in server/src/auth/better-auth.ts:89-93: The environment variable isn't documented in the deployment guide, so operators don't know it exists. Step 2: Sign in Capture the session cookie from the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-68qg-g8mg-6pr7

  2. Revision 2 · amended ·

    Amended from osv record GHSA-68qg-g8mg-6pr7

  3. Revision 1 · created ·

    Published from ghsa record GHSA-68qg-g8mg-6pr7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41679

Advisory: paperclip Vulnerable to Unauthenticated Remote Code Execution via Import Authorization Bypass
IDs: CVE-2026-41679, GHSA-68qg-g8mg-6pr7
Record: https://patchnext.com/advisories/cve-2026-41679 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: paperclipai 2026.410.0; @paperclipai/server 2026.410.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm paperclipai: affected < 2026.410.0; fixed in 2026.410.0
- npm @paperclipai/server: affected < 2026.410.0; fixed in 2026.410.0

## Suggested inspection (read-only)
- `npm ls paperclipai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @paperclipai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on paperclipai, @paperclipai/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-68qg-g8mg-6pr7 (GitHub-reviewed advisory GHSA-68qg-g8mg-6pr7 lists affected ranges: npm paperclipai >=0 =0 <2026.410.0)
- Verified: https://osv.dev/vulnerability/GHSA-68qg-g8mg-6pr7 (OSV record GHSA-68qg-g8mg-6pr7 lists affected ranges: npm paperclipai >=0 =0 <2026.410.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…