Skip to content

← Actionable
Medium, CVSS 5.3amended

Weblate Vulnerable to Authenticated SSRF via Project Backup Import bypassing validate_repo_url

CVE-2026-41654GHSA-cwcx-382v-8m9g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (weblate 5.17.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI weblate

    Affected
    < 5.17.1
    Fixed in
    5.17.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-41654: 0.37% estimated exploitation activity in the next 30 days; percentile 31.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with project.add permission (default on hosted Weblate SaaS and for any user holding an active billing/trial plan) can import a crafted project backup ZIP whose components/<name.json contains an attacker-chosen repo URL pointing at a private address (e.g. http://127.0.0.1:9999/) or using a non-allow-listed scheme (e.g. file://, git://). Weblate persists the component via Component.objects.bulkcreate([component])[0], which bypasses Django's fullclean() and therefore never runs the validaterepourl validator. The URL is subsequently written verbatim into .git/config by configurerepo(pull=False). Patches https://github.com/WeblateOrg/weblate/pull/19061 https://github.com/WeblateOrg/weblate/pull/19062 Workarounds Limiting who can create projects limits the scope. Resources Weblate thanks @fg0x0 for reporting this vulnerability via GitHub.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cwcx-382v-8m9g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cwcx-382v-8m9g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41654

Advisory: Weblate Vulnerable to Authenticated SSRF via Project Backup Import bypassing validate_repo_url
IDs: CVE-2026-41654, GHSA-cwcx-382v-8m9g
Record: https://patchnext.com/advisories/cve-2026-41654 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: weblate 5.17.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI weblate: affected < 5.17.1; fixed in 5.17.1

## Suggested inspection (read-only)
- `python -m pip show weblate`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on weblate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cwcx-382v-8m9g (OSV record GHSA-cwcx-382v-8m9g lists affected ranges: PyPI weblate >=0 <5.17.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cwcx-382v-8m9g (GitHub-reviewed advisory GHSA-cwcx-382v-8m9g lists affected ranges: PyPI weblate >=0 <5.17.1)

Commands are suggestions: review each one before running it.

Loading voting…