Skip to content

← Actionable
Medium, CVSS 6.1amended

fast-xml-parser XMLBuilder: XML Comment and CDATA Injection via Unescaped Delimiters

CVE-2026-41650GHSA-gh4j-gqv2-49f6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 5.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-41650: 0.24% estimated exploitation activity in the next 30 days; percentile 14.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

fast-xml-parser XMLBuilder: Comment and CDATA Injection via Unescaped Delimiters Summary fast-xml-parser XMLBuilder does not escape the -- sequence in comment content or the ]] sequence in CDATA sections when building XML from JavaScript objects. This allows XML injection when user-controlled data flows into comments or CDATA elements, leading to XSS, SOAP injection, or data manipulation. Existing CVEs for fast-xml-parser cover different issues: - CVE-2023-26920: Prototype pollution (parser) - CVE-2023-34104: ReDoS (parser) - CVE-2026-27942: Stack overflow in XMLBuilder with preserveOrder - CVE-2026-25896: Entity encoding bypass via regex in DOCTYPE entities This finding covers unescaped comment/CDATA delimiters in XMLBuilder - a distinct vulnerability. Vulnerable Code File: src/fxb.js Compare with attribute/text escaping which IS properly handled via replaceEntitiesValue(). Proof of Concept Test 1: Comment Injection (XSS in SVG/HTML context) Output: Test 2: CDATA Injection (RSS…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gh4j-gqv2-49f6

  2. Revision 1 · created ·

    Published from osv record GHSA-gh4j-gqv2-49f6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41650

Advisory: fast-xml-parser XMLBuilder: XML Comment and CDATA Injection via Unescaped Delimiters
IDs: CVE-2026-41650, GHSA-gh4j-gqv2-49f6
Record: https://patchnext.com/advisories/cve-2026-41650 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 5.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-xml-parser: affected < 5.7.0; fixed in 5.7.0

## Suggested inspection (read-only)
- `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-xml-parser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gh4j-gqv2-49f6 (OSV record GHSA-gh4j-gqv2-49f6 lists affected ranges: npm fast-xml-parser >=0 <5.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-gh4j-gqv2-49f6 (GitHub-reviewed advisory GHSA-gh4j-gqv2-49f6 lists affected ranges: npm fast-xml-parser >=0 <5.7.0)

Commands are suggestions: review each one before running it.

Loading voting…