Skip to content

← Actionable
High, CVSS 7.5amended

@nocobase/database has SQL Injection via String Concatenation through Recursive Eager Loading

CVE-2026-41640GHSA-4948-f92q-f432

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nocobase/database 2.0.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41640: 1.88% estimated exploitation activity in the next 30 days; percentile 79.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The queryParentSQL() function in the core database package constructs a recursive CTE query by joining nodeIds with string concatenation instead of using parameterized queries. The nodeIds array contains primary key values read from database rows. An attacker who can create a record with a malicious string primary key can inject arbitrary SQL when any subsequent request triggers recursive eager loading on that collection. Affected component: @nocobase/database (core) Affected versions: <= 2.0.32 (confirmed) Minimum privilege: Any user with record-creation permission on a tree collection with string-type primary keys Vulnerable Code packages/core/database/src/eager-loading/eager-loading-tree.ts:59-84 This function is called at line 384 when a BelongsTo association has recursively: true and instances exist: PoC The payload keeps the CTE syntactically valid by injecting a third UNION ALL branch. The closing ') from the original template literal completes the injected WHERE…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4948-f92q-f432

  2. Revision 1 · created ·

    Published from osv record GHSA-4948-f92q-f432

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41640

Advisory: @nocobase/database has SQL Injection via String Concatenation through Recursive Eager Loading
IDs: CVE-2026-41640, GHSA-4948-f92q-f432
Record: https://patchnext.com/advisories/cve-2026-41640 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @nocobase/database 2.0.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @nocobase/database: affected < 2.0.39; fixed in 2.0.39

## Suggested inspection (read-only)
- `npm ls @nocobase/database --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @nocobase/database.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4948-f92q-f432 (OSV record GHSA-4948-f92q-f432 lists affected ranges: npm @nocobase/database >=0 <2.0.39 (fixed))
- Verified: https://github.com/advisories/GHSA-4948-f92q-f432 (GitHub-reviewed advisory GHSA-4948-f92q-f432 lists affected ranges: npm @nocobase/database >=0 <2.0.39)

Commands are suggestions: review each one before running it.

Loading voting…