Skip to content

← Actionable
High, CVSS 8.6

CI4MS has Unrestricted PHP File Upload via Theme Installation that Leads to Authenticated Remote Code Execution

CVE-2026-41587GHSA-fw49-9xq4-gmx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.31.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41587: 0.62% estimated exploitation activity in the next 30 days; percentile 49.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A theme upload feature allows any authenticated backend user with theme-upload permission to achieve remote code execution (RCE) by uploading a crafted ZIP file. PHP files inside the ZIP are installed into the web-accessible public/ directory with no extension or content filtering, making them directly executable via HTTP. Details File: modules/Theme/Controllers/Theme.php After a ZIP is uploaded and extracted to a temporary directory, installthemefromtmp() is called unconditionally: Theme.php:51-52 File: modules/Theme/Helpers/themeshelper.php The helper copies every file matching . from public/templates/<name/ inside the ZIP directly into public/templates/<name/ on disk using rename(), with no file-extension allowlist, no MIME check, and no content inspection: themeshelper.php:60-68 Because the web root is public/, any .php file placed there is directly reachable over HTTP. PHP files are also installed — without filtering — into app/Controllers/templates/<name/,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fw49-9xq4-gmx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41587

Advisory: CI4MS has Unrestricted PHP File Upload via Theme Installation that Leads to Authenticated Remote Code Execution
IDs: CVE-2026-41587, GHSA-fw49-9xq4-gmx6
Record: https://patchnext.com/advisories/cve-2026-41587 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.31.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ci4-cms-erp/ci4ms: affected >= 0.26.0.0, <= 0.31.6.0; fixed in 0.31.7.0

## Suggested inspection (read-only)
- Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ci4-cms-erp/ci4ms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fw49-9xq4-gmx6 (GitHub-reviewed advisory GHSA-fw49-9xq4-gmx6 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0.26.0.0 <=0.31.6.0)

Commands are suggestions: review each one before running it.

Loading voting…