Skip to content

← Actionable
Medium, CVSS 6.9

Zebra Vulnerable to Denial of Service via Interrupted JSON-RPC Requests from Authenticated Clients

CVE-2026-41585GHSA-29x4-r6jv-ff4w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zebra-rpc 6.0.2; zebrad 4.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io zebra-rpc

    Affected
    >= 1.0.0-beta.45, < 6.0.2
    Fixed in
    6.0.2
  • crates.io zebrad

    Affected
    >= 2.2.0, < 4.3.1
    Fixed in
    4.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
EPSS
  • CVE-2026-41585: 0.26% estimated exploitation activity in the next 30 days; percentile 17.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in Zebra's JSON-RPC HTTP middleware allows an authenticated RPC client to cause a Zebra node to crash by disconnecting before the request body is fully received. The node treats the failure to read the HTTP request body as an unrecoverable error and aborts the process instead of returning an error response. Severity Moderate - This is a Denial of Service (DoS) that requires a client capable of passing Zebra's cookie authentication, which is enabled by default. Affected Versions - zebrad: versions from 2.2.0 up to (but not including) 4.3.1 - zebra-rpc: versions from 1.0.0-beta.45 up to (but not including) 6.0.2 Description Zebra's JSON-RPC HTTP middleware treated a failure to read the incoming HTTP request body as an unrecoverable error, aborting the process rather than returning an error response. A client that disconnected after sending only part of a request body, for example, by resetting the TCP connection mid-transfer, was sufficient to trigger the crash. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-29x4-r6jv-ff4w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41585

Advisory: Zebra Vulnerable to Denial of Service via Interrupted JSON-RPC Requests from Authenticated Clients
IDs: CVE-2026-41585, GHSA-29x4-r6jv-ff4w
Record: https://patchnext.com/advisories/cve-2026-41585 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zebra-rpc 6.0.2; zebrad 4.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io zebra-rpc: affected >= 1.0.0-beta.45, < 6.0.2; fixed in 6.0.2
- crates.io zebrad: affected >= 2.2.0, < 4.3.1; fixed in 4.3.1

## Suggested inspection (read-only)
- crates.io zebra-rpc: check the installed version with your package manager.
- crates.io zebrad: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zebra-rpc, zebrad.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29x4-r6jv-ff4w (GitHub-reviewed advisory GHSA-29x4-r6jv-ff4w lists affected ranges: crates.io zebra-rpc >=1.0.0-beta.45 =2.2.0 <4.3.1)

Commands are suggestions: review each one before running it.

Loading voting…