Skip to content

← Actionable
High, CVSS 8.7amended

OpenAM has LDAP Injection via _queryId Parameter

CVE-2026-41573GHSA-2vg8-q4c2-5cw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-core-rest 16.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41573: 0.50% estimated exploitation activity in the next 30 days; percentile 42.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenAM (Open Identity Platform) is an open-source IAM platform providing SSO, OAuth2, SAML, and OpenID Connect capabilities. The CREST REST API layer exposes user query endpoints under `/json/{realm}/users`. In `IdentityResourceV1.queryCollection()`, the HTTP query parameter `_queryId` is passed to a `CrestQuery` object with `escapeQueryId` explicitly set to `false`, bypassing the escape protection introduced as part of the CVE-2021-29156 fix. The unescaped value flows directly to `DJLDAPv3Repo.getFilter()` where it is concatenated into an LDAP filter string without sanitization, enabling authenticated attackers to inject arbitrary LDAP metacharacters for user enumeration and blind LDAP injection.

Affected Endpoint | Endpoint | Auth Required | Injection Parameter | |----------|--------------|---------------------| | `GET /openam/json/{realm}/users?_queryId= ` | SSO Token | `_queryId` | | `GET /openam/json/{realm}/groups?_queryId= ` | SSO Token (TBD) | `_queryId` | ##…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-2vg8-q4c2-5cw3

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-2vg8-q4c2-5cw3

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2vg8-q4c2-5cw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41573

Advisory: OpenAM has LDAP Injection via `_queryId` Parameter
IDs: CVE-2026-41573, GHSA-2vg8-q4c2-5cw3
Record: https://patchnext.com/advisories/cve-2026-41573 (revision 3, source checked 29 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-core-rest 16.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.openidentityplatform.openam:openam-core-rest: affected < 16.1.1; fixed in 16.1.1

## Suggested inspection (read-only)
- Maven org.openidentityplatform.openam:openam-core-rest: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.openidentityplatform.openam:openam-core-rest.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2vg8-q4c2-5cw3 (GitHub-reviewed advisory GHSA-2vg8-q4c2-5cw3 lists affected ranges: Maven org.openidentityplatform.openam:openam-core-rest >=0 <=16.0.6)
- Verified: https://osv.dev/vulnerability/GHSA-2vg8-q4c2-5cw3 (OSV record GHSA-2vg8-q4c2-5cw3 lists affected ranges: Maven org.openidentityplatform.openam:openam-core-rest >=0 <16.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…