Skip to content

← Actionable
High, CVSS 7.5amended

vLLM: Security Check Bypass via assert Statement in Activation Function Loading Allows Arbitrary Code Execution

CVE-2026-41523GHSA-q8gq-377p-jq3r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.22.0
    Fixed in
    0.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41523: 0.91% estimated exploitation activity in the next 30 days; percentile 60.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An assert-based security check in vLLM's activation function loading allows any unauthenticated attacker to achieve arbitrary code execution on the server by publishing a malicious HuggingFace model, when vLLM runs in Python optimized mode (python -O or PYTHONOPTIMIZE=1). Details vLLM uses an assert statement at vllm/modelexecutor/layers/pooler/activations.py:48 as its sole security control to restrict which activation functions can be loaded from a HuggingFace model's config.json: Python's assert statements are stripped at compile time when running in optimized mode (python -O or PYTHONOPTIMIZE=1). When the assert is absent, the attacker-controlled functionname from the model's config.json is passed directly to resolveobjbyqualname() — an unrestricted import gadget: This is the same vulnerability class as CVE-2017-1000433 (pysaml2 assert-based auth bypass), flagged by Bandit B101 and Ruff S101, and the reason Django proactively replaced all assert-based security checks…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q8gq-377p-jq3r

  2. Revision 1 · created ·

    Published from osv record GHSA-q8gq-377p-jq3r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41523

Advisory: vLLM: Security Check Bypass via assert Statement in Activation Function Loading Allows Arbitrary Code Execution
IDs: CVE-2026-41523, GHSA-q8gq-377p-jq3r
Record: https://patchnext.com/advisories/cve-2026-41523 (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q8gq-377p-jq3r (OSV record GHSA-q8gq-377p-jq3r lists affected ranges: PyPI vllm >=0 <0.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q8gq-377p-jq3r (GitHub-reviewed advisory GHSA-q8gq-377p-jq3r lists affected ranges: PyPI vllm >=0 <0.22.0)

Commands are suggestions: review each one before running it.

Loading voting…