Remote Code Execution (RCE) via String Literal Injection into math-codegen
CVE-2026-41507GHSA-p6x5-p4xf-cc4r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (math-codegen 0.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm math-codegen
- Affected
- < 0.4.3
- Fixed in
- 0.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p6x5-p4xf-cc4r lists affected ranges: npm math-codegen >=0 <0.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p6x5-p4xf-cc4r lists affected ranges: npm math-codegen >=0 <0.4.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-41507: 0.39% estimated exploitation activity in the next 30 days; percentile 33.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact String literal content passed to cg.parse() is injected verbatim into a new Function() body without sanitization. This allows an attacker to execute arbitrary system commands when user-controlled input reaches the parser. Any application exposing a math evaluation endpoint where user input flows into cg.parse() is vulnerable to full RCE. Patches The vulnerability is addressed by using JSON.stringify() on string literal values in lib/node/ConstantNode.js to ensure they are treated as data rather than code. Users should upgrade to version 0.4.3 or later. Workarounds Avoid passing un-sanitized user input to the parser or manually escape string literals in the input.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p6x5-p4xf-cc4r
- Revision 2 · amended ·
Amended from osv record GHSA-p6x5-p4xf-cc4r
- Revision 1 · created ·
Published from ghsa record GHSA-p6x5-p4xf-cc4r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41507 Advisory: Remote Code Execution (RCE) via String Literal Injection into math-codegen IDs: CVE-2026-41507, GHSA-p6x5-p4xf-cc4r Record: https://patchnext.com/advisories/cve-2026-41507 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: math-codegen 0.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm math-codegen: affected < 0.4.3; fixed in 0.4.3 ## Suggested inspection (read-only) - `npm ls math-codegen --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on math-codegen. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p6x5-p4xf-cc4r (GitHub-reviewed advisory GHSA-p6x5-p4xf-cc4r lists affected ranges: npm math-codegen >=0 <0.4.3) - Verified: https://osv.dev/vulnerability/GHSA-p6x5-p4xf-cc4r (OSV record GHSA-p6x5-p4xf-cc4r lists affected ranges: npm math-codegen >=0 <0.4.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…