Skip to content

← Actionable
Critical, CVSS 9.8amended

electerm has Command Injection via runLinux funtion

CVE-2026-41501GHSA-8x35-hph8-37hq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electerm 3.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electerm

    Affected
    < 3.3.8
    Fixed in
    3.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41501: 1.29% estimated exploitation activity in the next 30 days; percentile 70.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Command Injection vulnerabilities in electerm: A command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. Who is impacted: Users who run npm install -g electerm in Linux. An attacker who can control the remote release metadata (version string or release name) served by the project's update server could execute arbitrary system commands, tamper local files, and escalate compromise of development/runtime assets. --- Patches Has the problem been patched? What versions should users upgrade to? Fixed in 59708b38c8a52f5db59d7d4eff98e31d573128ee, user no need to upgrade, the new version already published in npm --- Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? no

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8x35-hph8-37hq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8x35-hph8-37hq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8x35-hph8-37hq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41501

Advisory: electerm has Command Injection via runLinux funtion
IDs: CVE-2026-41501, GHSA-8x35-hph8-37hq
Record: https://patchnext.com/advisories/cve-2026-41501 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electerm 3.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electerm: affected < 3.3.8; fixed in 3.3.8

## Suggested inspection (read-only)
- `npm ls electerm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electerm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8x35-hph8-37hq (GitHub-reviewed advisory GHSA-8x35-hph8-37hq lists affected ranges: npm electerm >=0 <3.3.8)
- Verified: https://osv.dev/vulnerability/GHSA-8x35-hph8-37hq (OSV record GHSA-8x35-hph8-37hq lists affected ranges: npm electerm >=0 <3.3.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…