Skip to content

← Actionable
High, CVSS 8.9amended

Ray: Remote Code Execution via Parquet Arrow Extension Type Deserialization

CVE-2026-41486GHSA-mw35-8rx3-xf9r

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ve-ray

    Affected
    <= 2.54.0
    Fixed in
    no fixed version recorded
  • PyPI ray

    Affected
    >= 2.49.0, < 2.55.0
    Fixed in
    2.55.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-41486: 0.47% estimated exploitation activity in the next 30 days; percentile 40.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Ray Data registers custom Arrow extension types (ray.data.arrowtensor, ray.data.arrowtensorv2, ray.data.arrowvariableshapedtensor) globally in PyArrow. When PyArrow reads a Parquet file containing one of these extension types, it calls arrowextdeserialize on the field's metadata bytes. Ray's implementation passes these bytes directly to cloudpickle.loads(), achieving arbitrary code execution during schema parsing, before any row data is read. In May 2024, Ray fixed a related vulnerability in PyExtensionType-based extension types (issue #41314, PR #45084). In July 2025, PR #54831 introduced cloudpickle.loads() into the replacement extension types' deserialization path, reintroducing the same class of vulnerability. Impact - Affected versions: Ray 2.49.0 through 2.54.0 (latest release as of March 2026). The vulnerable deserializewithfallback function with cloudpickle.loads() was introduced in commit f6d21db1a4 (PR #54831, July 2025), first released in Ray 2.49.0. - Affected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-mw35-8rx3-xf9r

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record PYSEC-2026-2296

  4. Revision 1 · created ·

    Published from osv record GHSA-mw35-8rx3-xf9r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41486

Advisory: Ray: Remote Code Execution via Parquet Arrow Extension Type Deserialization
IDs: CVE-2026-41486, GHSA-mw35-8rx3-xf9r
Record: https://patchnext.com/advisories/cve-2026-41486 (revision 4, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: ray 2.55.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ve-ray: affected <= 2.54.0
- PyPI ray: affected >= 2.49.0, < 2.55.0; fixed in 2.55.0

## Suggested inspection (read-only)
- `python -m pip show ve-ray`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show ray`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ve-ray, ray.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mw35-8rx3-xf9r (OSV record GHSA-mw35-8rx3-xf9r lists affected ranges: PyPI ray >=2.49.0 <2.55.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2026-2296 (OSV record PYSEC-2026-2296 lists affected ranges: PyPI ve-ray >=0 <=2.54.0)
- Verified: https://github.com/advisories/GHSA-mw35-8rx3-xf9r (GitHub-reviewed advisory GHSA-mw35-8rx3-xf9r lists affected ranges: PyPI ray >=2.49.0 <2.55.0)

Commands are suggestions: review each one before running it.

Loading voting…