Authlib OAuth 2.0 has Open Redirect in Authorization API that allows attacker-controlled redirect_uri through unsupported response_type
CVE-2026-41479GHSA-w8p2-r796-3vmq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.7.1, 1.6.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI authlib
- Affected
- < 1.6.10>= 1.7.0, <= 1.7.0
- Fixed in
- 1.6.10, 1.7.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w8p2-r796-3vmq lists affected ranges: PyPI authlib >=0 =1.7.0 <1.7.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8p2-r796-3vmq lists affected ranges: PyPI authlib >=0 =1.7.0 <=1.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-41479: 0.26% estimated exploitation activity in the next 30 days; percentile 17.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Authlib's OAuth 2.0 authorization endpoint can be turned into an unauthenticated open redirect when a request uses an unsupported responsetype and supplies an attacker-controlled redirecturi. The vulnerable behavior happens before client lookup and before any redirect URI validation. As a result, an attacker does not need a valid client registration, an authenticated user, or any prior state. A single request to the authorization endpoint is enough to obtain a 302 Location response to an arbitrary attacker-controlled URL. It was confirmed that the vulnerable code is present in tag v1.6.6 and in the current HEAD under test (68e6ab3fdfc71a328b1966bad5c6aba0f7d0c2e1, git describe: v1.6.6-104-g68e6ab3f). The issue was dynamically reproduced locally on the current HEAD. Details The root cause is that AuthorizationServer.getauthorizationgrant() copies the raw request redirecturi into an UnsupportedResponseTypeError before any client has been resolved and before any redirect URI…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w8p2-r796-3vmq
- Revision 1 · created ·
Published from osv record GHSA-w8p2-r796-3vmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41479 Advisory: Authlib OAuth 2.0 has Open Redirect in Authorization API that allows attacker-controlled redirect_uri through unsupported response_type IDs: CVE-2026-41479, GHSA-w8p2-r796-3vmq Record: https://patchnext.com/advisories/cve-2026-41479 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: authlib 1.7.1, 1.6.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI authlib: affected < 1.6.10; >= 1.7.0, <= 1.7.0; fixed in 1.6.10, 1.7.1 ## Suggested inspection (read-only) - `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on authlib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w8p2-r796-3vmq (OSV record GHSA-w8p2-r796-3vmq lists affected ranges: PyPI authlib >=0 =1.7.0 <1.7.1 (fixed)) - Verified: https://github.com/advisories/GHSA-w8p2-r796-3vmq (GitHub-reviewed advisory GHSA-w8p2-r796-3vmq lists affected ranges: PyPI authlib >=0 =1.7.0 <=1.7.0) Commands are suggestions: review each one before running it.
Loading voting…