OAuth 2.1 Provider: Unprivileged users can register OAuth clients
CVE-2026-41427GHSA-xr8f-h2gw-9xh6
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @better-auth/oauth-provider
- Affected
- >= 1.4.8-beta.7, < 1.6.5>= 1.7.0-beta.0, <= 1.7.0-beta.1
- Fixed in
- 1.6.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xr8f-h2gw-9xh6 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8-beta.7 =1.7.0-beta.0 <=1.7.0-beta.1
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xr8f-h2gw-9xh6 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8-beta.7 =1.7.0-beta.0 <=1.7.0-beta.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N · score source
- EPSS
- CVE-2026-41427: 0.21% estimated exploitation activity in the next 30 days; percentile 11.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? You're affected if all of the following are true: - Using @better-auth/oauth-provider at version specified below - You configured clientPrivileges in the plugin options expecting it to gate who can create OAuth clients - The /oauth2/create-client or /admin/oauth2/create-client endpoints are reachable by authenticated users you don't fully trust If clientPrivileges is not configured, this bug has no security consequence for your deployment ---
Summary The clientPrivileges option documents a create action, but the OAuth client creation endpoints did not invoke the hook before persisting new clients. Deployments that configured clientPrivileges to restrict client registration were not actually restricted — any authenticated user could reach the create endpoints and register an OAuth client with attacker-chosen redirect URIs and metadata. Non-create operations (read, list, update, delete, rotate) enforced the hook correctly. Only the create path was missing the check.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xr8f-h2gw-9xh6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xr8f-h2gw-9xh6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41427 Advisory: OAuth 2.1 Provider: Unprivileged users can register OAuth clients IDs: CVE-2026-41427, GHSA-xr8f-h2gw-9xh6 Record: https://patchnext.com/advisories/cve-2026-41427 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @better-auth/oauth-provider 1.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @better-auth/oauth-provider: affected >= 1.4.8-beta.7, < 1.6.5; >= 1.7.0-beta.0, <= 1.7.0-beta.1; fixed in 1.6.5 ## Suggested inspection (read-only) - `npm ls @better-auth/oauth-provider --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @better-auth/oauth-provider. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xr8f-h2gw-9xh6 (OSV record GHSA-xr8f-h2gw-9xh6 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8-beta.7 =1.7.0-beta.0 <=1.7.0-beta.1) - Verified: https://github.com/advisories/GHSA-xr8f-h2gw-9xh6 (GitHub-reviewed advisory GHSA-xr8f-h2gw-9xh6 lists affected ranges: npm @better-auth/oauth-provider >=1.4.8-beta.7 =1.7.0-beta.0 <=1.7.0-beta.1) Commands are suggestions: review each one before running it.
Loading voting…