Skip to content

← Actionable
Medium, CVSS 5.4amended

Authlib: Cross-site request forging when using cache

CVE-2026-41425GHSA-jj8c-mmj3-mmgv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.6.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI authlib

    Affected
    < 1.6.11
    Fixed in
    1.6.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-41425: 0.11% estimated exploitation activity in the next 30 days; percentile 1.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary There is no CSRF protection on the cache feature on most integrations clients. Details In authlib.integrations.starletteclient.OAuth, no CSRF protection is set up when using the cache parameter. When not using the cache parameter, the use of SessionMiddleware ties the client to the auth state, preventing CSRF attacks. With the cache, there is no such mechanism. Other integratons have the same issue, it's not just starlette. The state parameter is taken from the callback URL and the state is fetched from the cache without checking that it is the same client calling the redirect endpoint as was the one that initiated the auth flow. This issue is documented in RFC 6749 section 10.12: https://datatracker.ietf.org/doc/html/rfc6749#section-10.12 PoC - Set up a Starlette integration with a cache - The attacker starts the auth flow up until before the callback URL is followed. - The attacked sends the redirect URL to the victim - The victim now completes the authorisation Impact This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jj8c-mmj3-mmgv

  2. Revision 1 · created ·

    Published from osv record GHSA-jj8c-mmj3-mmgv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41425

Advisory: Authlib: Cross-site request forging when using cache
IDs: CVE-2026-41425, GHSA-jj8c-mmj3-mmgv
Record: https://patchnext.com/advisories/cve-2026-41425 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlib 1.6.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI authlib: affected < 1.6.11; fixed in 1.6.11

## Suggested inspection (read-only)
- `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jj8c-mmj3-mmgv (OSV record GHSA-jj8c-mmj3-mmgv lists affected ranges: PyPI authlib >=0 <1.6.11 (fixed))
- Verified: https://github.com/advisories/GHSA-jj8c-mmj3-mmgv (GitHub-reviewed advisory GHSA-jj8c-mmj3-mmgv lists affected ranges: PyPI authlib >=0 <1.6.11)

Commands are suggestions: review each one before running it.

Loading voting…