Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server
CVE-2026-41423GHSA-45q2-gjvg-7973
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 22.0.0-next.0, < 22.0.0-next.8>= 21.0.0-next.0, < 21.2.9>= 20.0.0-next.0, < 20.3.19>= 19.0.0-next.0, < 19.2.21<= 18.2.14
- Fixed in
- 21.2.9, 20.3.19, 22.0.0-next.8, 19.2.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-45q2-gjvg-7973 lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-45q2-gjvg-7973 lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-41423: 0.30% estimated exploitation activity in the next 30 days; percentile 23.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR). When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions. Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. Affected APIs: - renderModule - renderApplication - CommonEngine (from @angular/ssr) Non-Affected APIs: - AngularAppEngine (from @angular/ssr) - AngularNodeAppEngine (from @angular/ssr) Attack…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-45q2-gjvg-7973
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-45q2-gjvg-7973
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41423 Advisory: Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server IDs: CVE-2026-41423, GHSA-45q2-gjvg-7973 Record: https://patchnext.com/advisories/cve-2026-41423 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/platform-server 22.0.0-next.8, 21.2.9, 20.3.19, 19.2.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/platform-server: affected >= 22.0.0-next.0, < 22.0.0-next.8; >= 21.0.0-next.0, < 21.2.9; >= 20.0.0-next.0, < 20.3.19; >= 19.0.0-next.0, < 19.2.21; <= 18.2.14; fixed in 21.2.9, 20.3.19, 22.0.0-next.8, 19.2.21 ## Suggested inspection (read-only) - `npm ls @angular/platform-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/platform-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-45q2-gjvg-7973 (OSV record GHSA-45q2-gjvg-7973 lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) - Verified: https://github.com/advisories/GHSA-45q2-gjvg-7973 (GitHub-reviewed advisory GHSA-45q2-gjvg-7973 lists affected ranges: npm @angular/platform-server >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) Commands are suggestions: review each one before running it.
Loading voting…