Skip to content

← Actionable
Medium, CVSS 6.3amended

OpenClaw: Shell init-file options could satisfy exec allowlist script matching

CVE-2026-41392GHSA-wpc6-37g7-8q4w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.31), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.3.31
    Fixed in
    2026.3.31

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41392: 0.12% estimated exploitation activity in the next 30 days; percentile 1.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Before OpenClaw 2026.3.31, exec allowlist matching could treat shell init-file wrapper invocations as if the approved script itself were being executed. Shell options such as --rcfile, --init-file, and --startup-file could therefore inherit allowlist trust from a matched script path even though the shell loaded attacker-chosen initialization first. Impact This issue only applied when exec allowlist or allow-always behavior was enabled and the attacker could steer a shell-wrapper command shape that used init-file options. The result was a narrower allowlist bypass, not generic arbitrary command execution from an untrusted boundary. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: < 2026.3.31 - Patched versions: = 2026.3.31 - Latest published npm version: 2026.4.1 Fix Commit(s) - 0c8375424620e12777ef24c162eedc7e9fcfd7e3 — reject shell init-file script matches Release Process Note The fix shipped in OpenClaw 2026.3.31 on March 31, 2026. The current…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wpc6-37g7-8q4w

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wpc6-37g7-8q4w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41392

Advisory: OpenClaw: Shell init-file options could satisfy exec allowlist script matching
IDs: CVE-2026-41392, GHSA-wpc6-37g7-8q4w
Record: https://patchnext.com/advisories/cve-2026-41392 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.31. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.3.31; fixed in 2026.3.31

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wpc6-37g7-8q4w (OSV record GHSA-wpc6-37g7-8q4w lists affected ranges: npm openclaw >=0 <2026.3.31 (fixed))
- Verified: https://github.com/advisories/GHSA-wpc6-37g7-8q4w (GitHub-reviewed advisory GHSA-wpc6-37g7-8q4w lists affected ranges: npm openclaw >=0 <2026.3.31)

Commands are suggestions: review each one before running it.

Loading voting…