Skip to content

← Actionable
High, CVSS 8.5amended

OpenClaw's incomplete host env sanitization blocklist allows supply-chain redirection via package-manager env overrides

CVE-2026-41387GHSA-j7p2-qcwm-94v4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.3.22
    Fixed in
    2026.3.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41387: 0.24% estimated exploitation activity in the next 30 days; percentile 15.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Host exec env override sanitization did not fail closed for several package-manager and related redirect variables that can steer dependency fetches or startup behavior. Impact An approved exec request could silently redirect package resolution or runtime bootstrap to attacker-controlled infrastructure and execute trojanized content. Affected Component src/infra/host-env-security-policy.json, src/infra/host-env-security.ts Fixed Versions - Affected: < 2026.3.22 - Patched: = 2026.3.22 Fix Fixed by commit 7abfff756d (Exec: harden host env override handling across gateway and node).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j7p2-qcwm-94v4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j7p2-qcwm-94v4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41387

Advisory: OpenClaw's incomplete host env sanitization blocklist allows supply-chain redirection via package-manager env overrides
IDs: CVE-2026-41387, GHSA-j7p2-qcwm-94v4
Record: https://patchnext.com/advisories/cve-2026-41387 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.3.22; fixed in 2026.3.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j7p2-qcwm-94v4 (OSV record GHSA-j7p2-qcwm-94v4 lists affected ranges: npm openclaw >=0 <2026.3.22 (fixed))
- Verified: https://github.com/advisories/GHSA-j7p2-qcwm-94v4 (GitHub-reviewed advisory GHSA-j7p2-qcwm-94v4 lists affected ranges: npm openclaw >=0 <2026.3.22)

Commands are suggestions: review each one before running it.

Loading voting…