OpenClaw SSRF guard misses four IPv6 special-use ranges
CVE-2026-41361GHSA-g86v-f9qv-rh6m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.3.24
- Fixed in
- 2026.3.28
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g86v-f9qv-rh6m lists affected ranges: npm openclaw >=0 <2026.3.28 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g86v-f9qv-rh6m lists affected ranges: npm openclaw >=0 <=2026.3.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-41361: 0.20% estimated exploitation activity in the next 30 days; percentile 10.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The SSRF/IP classifier treated several IPv6 special-use ranges as public and allowed fetches to proceed. Impact An attacker who controlled a fetched URL could target internal or non-routable IPv6 addresses that should have been blocked by the SSRF guard. Affected Component src/shared/net/ip.ts, src/infra/net/ssrf. Fixed Versions - Affected: <= 2026.3.24 - Patched: = 2026.3.28 - Latest stable 2026.3.28 contains the fix. Fix Fixed by commit d61f8e5672 (Net: block missing IPv6 special-use ranges). OpenClaw thanks @nicky-cc of Tencent zhuque Lab https://github.com/Tencent/AI-Infra-Guard for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g86v-f9qv-rh6m
- Revision 1 · created ·
Published from osv record GHSA-g86v-f9qv-rh6m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41361 Advisory: OpenClaw SSRF guard misses four IPv6 special-use ranges IDs: CVE-2026-41361, GHSA-g86v-f9qv-rh6m Record: https://patchnext.com/advisories/cve-2026-41361 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.28. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.3.24; fixed in 2026.3.28 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g86v-f9qv-rh6m (OSV record GHSA-g86v-f9qv-rh6m lists affected ranges: npm openclaw >=0 <2026.3.28 (fixed)) - Verified: https://github.com/advisories/GHSA-g86v-f9qv-rh6m (GitHub-reviewed advisory GHSA-g86v-f9qv-rh6m lists affected ranges: npm openclaw >=0 <=2026.3.24) Commands are suggestions: review each one before running it.
Loading voting…