OpenClaw: Slack thread context could include messages from non-allowlisted senders
CVE-2026-41358GHSA-qm77-8qjp-4vcm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.4.1
- Fixed in
- 2026.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qm77-8qjp-4vcm lists affected ranges: npm openclaw >=0 <2026.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qm77-8qjp-4vcm lists affected ranges: npm openclaw >=0 <=2026.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-41358: 0.14% estimated exploitation activity in the next 30 days; percentile 3.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Before OpenClaw 2026.4.2, Slack thread starter and thread-history context fetched through the API was not filtered by the effective sender allowlist. Messages from non-allowlisted senders could still enter the agent context when an allowlisted user replied in the same thread. Impact A Slack deployment that relied on sender allowlists could still feed non-allowlisted thread content into the model context through thread history. This was a sender-access-control bypass on Slack thread context, not a direct channel-auth bypass. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.4.1 - Patched versions: = 2026.4.2 - Latest published npm version: 2026.4.1 Fix Commit(s) - ac5bc4fb37becc64a2ec314864cca1565e921f2d — filter Slack thread context by the effective allowlist Release Process Note The fix is present on main and is staged for OpenClaw 2026.4.2. Publish this advisory after the 2026.4.2 npm release is live. OpenClaw thanks @AntAISecurityLab for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qm77-8qjp-4vcm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qm77-8qjp-4vcm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41358 Advisory: OpenClaw: Slack thread context could include messages from non-allowlisted senders IDs: CVE-2026-41358, GHSA-qm77-8qjp-4vcm Record: https://patchnext.com/advisories/cve-2026-41358 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.4.1; fixed in 2026.4.2 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qm77-8qjp-4vcm (OSV record GHSA-qm77-8qjp-4vcm lists affected ranges: npm openclaw >=0 <2026.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-qm77-8qjp-4vcm (GitHub-reviewed advisory GHSA-qm77-8qjp-4vcm lists affected ranges: npm openclaw >=0 <=2026.4.1) Commands are suggestions: review each one before running it.
Loading voting…