Skip to content

← Actionable
High, CVSS 7.1

Kirby is vulnerable to authorization bypass during page, file and user creation via blueprint injection

CVE-2026-41325GHSA-6gqr-mx34-wh8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.0, 4.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 4.9.0>= 5.0.0, < 5.4.0
    Fixed in
    4.9.0, 5.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41325: 0.36% estimated exploitation activity in the next 30 days; percentile 30.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby sites where users of a particular role have no permission to create pages, files or users (pages.create, files.create or users.create permission is disabled). This can be due to configuration in the user blueprint(s), via options in the model blueprint(s) or via a combination of both settings. This vulnerability is of high severity for affected sites. Developers' Kirby sites are not affected if they intend all users of their site to be able to create pages, files and users. The vulnerability can only be exploited by authenticated users. ---- Introduction An authorization bypass allows authenticated users to perform actions they should not be allowed to perform based on their configured permissions, thereby causing a privilege escalation. The effects of an authorization bypass can include unauthorized access to sensitive information as well as unauthorized changes to content or system information. Impact Kirby's user permissions control which…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6gqr-mx34-wh8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41325

Advisory: Kirby is vulnerable to authorization bypass during page, file and user creation via blueprint injection
IDs: CVE-2026-41325, GHSA-6gqr-mx34-wh8r
Record: https://patchnext.com/advisories/cve-2026-41325 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.0, 4.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 4.9.0; >= 5.0.0, < 5.4.0; fixed in 4.9.0, 5.4.0

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6gqr-mx34-wh8r (GitHub-reviewed advisory GHSA-6gqr-mx34-wh8r lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…