basic-ftp vulnerable to denial of service via unbounded memory consumption in Client.list()
CVE-2026-41324GHSA-rp42-5vxx-qpwr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (basic-ftp 5.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm basic-ftp
- Affected
- <= 5.2.2
- Fixed in
- 5.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rp42-5vxx-qpwr lists affected ranges: npm basic-ftp >=0 <5.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rp42-5vxx-qpwr lists affected ranges: npm basic-ftp >=0 <=5.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-41324: 0.33% estimated exploitation activity in the next 30 days; percentile 26.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary basic-ftp@5.2.2 is vulnerable to denial of service through unbounded memory growth while processing directory listings from a remote FTP server. A malicious or compromised server can send an extremely large or never-ending listing response to Client.list(), causing the client process to consume memory until it becomes unstable or crashes. Details The issue is in the package's default directory listing flow. Client.list() reaches dist/Client.js, where the full listing response is downloaded into a StringWriter before parsing: File: dist/Client.js:516-527 The vulnerable sink is StringWriter, which grows an in-memory Buffer with no limit: File: dist/StringWriter.js:5-20 The critical operation is: There is no maximum size check, no truncation, and no streaming parser. Because the remote FTP server controls the listing response, it can force the client to keep allocating memory until the process is terminated. How it happens: 1. An application connects to an attacker-controlled or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rp42-5vxx-qpwr
- Revision 1 · created ·
Published from osv record GHSA-rp42-5vxx-qpwr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41324 Advisory: basic-ftp vulnerable to denial of service via unbounded memory consumption in Client.list() IDs: CVE-2026-41324, GHSA-rp42-5vxx-qpwr Record: https://patchnext.com/advisories/cve-2026-41324 (revision 2, source checked 26 Oct 2026, 12:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: basic-ftp 5.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm basic-ftp: affected <= 5.2.2; fixed in 5.3.0 ## Suggested inspection (read-only) - `npm ls basic-ftp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on basic-ftp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rp42-5vxx-qpwr (OSV record GHSA-rp42-5vxx-qpwr lists affected ranges: npm basic-ftp >=0 <5.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rp42-5vxx-qpwr (GitHub-reviewed advisory GHSA-rp42-5vxx-qpwr lists affected ranges: npm basic-ftp >=0 <=5.2.2) Commands are suggestions: review each one before running it.
Loading voting…