Skip to content

← Actionable
High, CVSS 8.1

ERB has an @_init deserialization guard bypass via def_module / def_method / def_class

CVE-2026-41316GHSA-q339-8rmv-2mhv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (erb 6.0.4, 6.0.1.1, 4.0.4.1, 4.0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems erb

    Affected
    < 4.0.3.1>= 4.0.4, <= 4.0.4>= 5.0.0, < 6.0.1.1>= 6.0.2, < 6.0.4
    Fixed in
    4.0.3.1, 6.0.1.1, 4.0.4.1, 6.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41316: 1.13% estimated exploitation activity in the next 30 days; percentile 66.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Ruby 2.7.0 (before ERB 2.2.0 was published on rubygems.org) introduced an @init instance variable guard in ERB#result and ERB#run to prevent code execution when an ERB object is reconstructed via Marshal.load (deserialization). However, three other public methods that also evaluate @src via eval() were not given the same guard: - ERB#defmethod - ERB#defmodule - ERB#defclass An attacker who can trigger Marshal.load on untrusted data in a Ruby application that has erb loaded can use ERB#defmodule (zero-arg, default parameters) as a code execution sink, bypassing the @init protection entirely. <details The @init Guard In ERB#initialize, the guard is set: In ERB#result and ERB#run, the guard is checked before eval(@src): When an ERB object is reconstructed via Marshal.load, @init is either nil (not set during marshal reconstruction) or an attacker-controlled value. Since ERB.singletonclass cannot be marshaled, the attacker cannot set @init to the correct value, and result/run…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q339-8rmv-2mhv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41316

Advisory: ERB has an @_init deserialization guard bypass via def_module / def_method / def_class
IDs: CVE-2026-41316, GHSA-q339-8rmv-2mhv
Record: https://patchnext.com/advisories/cve-2026-41316 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: erb 6.0.4, 6.0.1.1, 4.0.4.1, 4.0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems erb: affected < 4.0.3.1; >= 4.0.4, <= 4.0.4; >= 5.0.0, < 6.0.1.1; >= 6.0.2, < 6.0.4; fixed in 4.0.3.1, 6.0.1.1, 4.0.4.1, 6.0.4

## Suggested inspection (read-only)
- RubyGems erb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on erb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q339-8rmv-2mhv (GitHub-reviewed advisory GHSA-q339-8rmv-2mhv lists affected ranges: RubyGems erb >=0 =4.0.4 =5.0.0 =6.0.2 <6.0.4)

Commands are suggestions: review each one before running it.

Loading voting…