PostCSS has XSS via Unescaped in its CSS Stringify Output
CVE-2026-41305GHSA-qx2v-qp2m-jg93
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (postcss 8.5.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm postcss
- Affected
- < 8.5.10
- Fixed in
- 8.5.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qx2v-qp2m-jg93 lists affected ranges: npm postcss >=0 <8.5.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qx2v-qp2m-jg93 lists affected ranges: npm postcss >=0 <8.5.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-41305: 0.21% estimated exploitation activity in the next 30 days; percentile 10.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PostCSS: XSS via Unescaped </style in CSS Stringify Output Summary PostCSS v8.5.5 (latest) does not escape </style sequences when stringifying CSS ASTs. When user-submitted CSS is parsed and re-stringified for embedding in HTML <style tags, </style in CSS values breaks out of the style context, enabling XSS. Proof of Concept Tested output (Node.js v22, postcss v8.5.5): Impact Impact non-bundler use cases since bundlers for XSS on their own. Requires some PostCSS plugin to have malware code, which can inject XSS to website. Suggested Fix Escape </style in all stringified output values: Credits Discovered and reported by Sunil Kumar (@TharVid)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qx2v-qp2m-jg93
- Revision 1 · created ·
Published from osv record GHSA-qx2v-qp2m-jg93
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41305 Advisory: PostCSS has XSS via Unescaped in its CSS Stringify Output IDs: CVE-2026-41305, GHSA-qx2v-qp2m-jg93 Record: https://patchnext.com/advisories/cve-2026-41305 (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: postcss 8.5.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm postcss: affected < 8.5.10; fixed in 8.5.10 ## Suggested inspection (read-only) - `npm ls postcss --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on postcss. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qx2v-qp2m-jg93 (OSV record GHSA-qx2v-qp2m-jg93 lists affected ranges: npm postcss >=0 <8.5.10 (fixed)) - Verified: https://github.com/advisories/GHSA-qx2v-qp2m-jg93 (GitHub-reviewed advisory GHSA-qx2v-qp2m-jg93 lists affected ranges: npm postcss >=0 <8.5.10) Commands are suggestions: review each one before running it.
Loading voting…