Skip to content

← Actionable
Unratedamended

OpenClaw: Gateway chat.send ACP-only provenance guard could be bypassed by client identity spoofing

CVE-2026-41299GHSA-6xg4-82hv-cp6f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.28), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.3.24
    Fixed in
    2026.3.28

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-41299: 0.20% estimated exploitation activity in the next 30 days; percentile 10.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ACP-only provenance fields in chat.send were gated by self-declared client metadata from the WebSocket handshake rather than verified authorization state. Impact A normal authenticated operator client could spoof ACP identity labels and inject reserved provenance fields intended only for the ACP bridge. Affected Component src/gateway/server-methods/chat.ts, src/gateway/server/ws-connection/message-handler.ts Fixed Versions - Affected: <= 2026.3.24 - Patched: = 2026.3.28 - Latest stable 2026.3.28 contains the fix. Fix Fixed by commit 4b9542716c (Gateway: require verified scope for chat provenance).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6xg4-82hv-cp6f

  2. Revision 1 · created ·

    Published from osv record GHSA-6xg4-82hv-cp6f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41299

Advisory: OpenClaw: Gateway chat.send ACP-only provenance guard could be bypassed by client identity spoofing
IDs: CVE-2026-41299, GHSA-6xg4-82hv-cp6f
Record: https://patchnext.com/advisories/cve-2026-41299 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.28. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.3.24; fixed in 2026.3.28

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6xg4-82hv-cp6f (OSV record GHSA-6xg4-82hv-cp6f lists affected ranges: npm openclaw >=0 <2026.3.28 (fixed))
- Verified: https://github.com/advisories/GHSA-6xg4-82hv-cp6f (GitHub-reviewed advisory GHSA-6xg4-82hv-cp6f lists affected ranges: npm openclaw >=0 <=2026.3.24)

Commands are suggestions: review each one before running it.

Loading voting…