OpenClaw: Untrusted workspace channel shadows could execute during built-in channel setup
CVE-2026-41295GHSA-2qrv-rc5x-2g2h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.4.1
- Fixed in
- 2026.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2qrv-rc5x-2g2h lists affected ranges: npm openclaw >=0 <2026.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2qrv-rc5x-2g2h lists affected ranges: npm openclaw >=0 <=2026.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-41295: 0.13% estimated exploitation activity in the next 30 days; percentile 2.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Before OpenClaw 2026.4.2, built-in channel setup and login could resolve an untrusted workspace channel shadow before the plugin was explicitly trusted. A malicious workspace plugin that claimed a bundled channel id could execute during channel setup even while still disabled. Impact A cloned workspace could turn channel setup for a built-in channel into unintended in-process code execution from an untrusted workspace plugin. This bypassed the intended workspace-plugin trust boundary during setup and login. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.4.1 - Patched versions: = 2026.4.2 - Latest published npm version: 2026.4.1 Fix Commit(s) - 53c29df2a9eb242a70d0ff29f3d1e67c8d6801f0 — ignore untrusted workspace channel shadows during setup resolution Release Process Note The fix is present on main and is staged for OpenClaw 2026.4.2. Publish this advisory after the 2026.4.2 npm release is live. Thanks @zpbrent for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2qrv-rc5x-2g2h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2qrv-rc5x-2g2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41295 Advisory: OpenClaw: Untrusted workspace channel shadows could execute during built-in channel setup IDs: CVE-2026-41295, GHSA-2qrv-rc5x-2g2h Record: https://patchnext.com/advisories/cve-2026-41295 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.4.1; fixed in 2026.4.2 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2qrv-rc5x-2g2h (OSV record GHSA-2qrv-rc5x-2g2h lists affected ranges: npm openclaw >=0 <2026.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2qrv-rc5x-2g2h (GitHub-reviewed advisory GHSA-2qrv-rc5x-2g2h lists affected ranges: npm openclaw >=0 <=2026.4.1) Commands are suggestions: review each one before running it.
Loading voting…