OpenClaw has a CWD .env environment variable injection which bypasses host-env policy and allows config takeover
CVE-2026-41294GHSA-8rh7-6779-cjqq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.3.24
- Fixed in
- 2026.3.28
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8rh7-6779-cjqq lists affected ranges: npm openclaw >=0 <=2026.3.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8rh7-6779-cjqq lists affected ranges: npm openclaw >=0 <2026.3.28 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-41294: 0.13% estimated exploitation activity in the next 30 days; percentile 2.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OpenClaw loaded the current working directory .env before trusted state-dir configuration, allowing untrusted workspace state to inject host environment values. Impact A repository or workspace containing a malicious .env file could override runtime configuration and security-sensitive environment settings when OpenClaw started there. Affected Component src/infra/dotenv.ts, src/cli/dotenv.ts Fixed Versions - Affected: <= 2026.3.24 - Patched: = 2026.3.28 - Latest stable 2026.3.28 contains the fix. Fix Fixed by commit 6a79324802 (Filter untrusted CWD .env entries before OpenClaw startup).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8rh7-6779-cjqq
- Revision 2 · amended ·
Amended from osv record GHSA-8rh7-6779-cjqq
- Revision 1 · created ·
Published from ghsa record GHSA-8rh7-6779-cjqq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41294 Advisory: OpenClaw has a CWD `.env` environment variable injection which bypasses host-env policy and allows config takeover IDs: CVE-2026-41294, GHSA-8rh7-6779-cjqq Record: https://patchnext.com/advisories/cve-2026-41294 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.28. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.3.24; fixed in 2026.3.28 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8rh7-6779-cjqq (GitHub-reviewed advisory GHSA-8rh7-6779-cjqq lists affected ranges: npm openclaw >=0 <=2026.3.24) - Verified: https://osv.dev/vulnerability/GHSA-8rh7-6779-cjqq (OSV record GHSA-8rh7-6779-cjqq lists affected ranges: npm openclaw >=0 <2026.3.28 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…