Skip to content

← Actionable
Critical, CVSS 9.9amended

OpenStack Mistral allows Arbitrary Remote Code Execution when the API is exposed

CVE-2026-41283GHSA-9hfw-w3f4-c4p8

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mistral

    Affected
    >= 20.0.0, < 20.1.1>= 21.0.0, <= 21.0.0>= 22.0.0, <= 22.0.0
    Fixed in
    20.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-41283: 0.73% estimated exploitation activity in the next 30 days; percentile 54.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenStack Mistral through 22.0.0 allows Arbitrary Remote Code Execution when the API is exposed. There are endpoints that allow code execution, which can lead to exfiltration of service credentials.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9hfw-w3f4-c4p8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9hfw-w3f4-c4p8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9hfw-w3f4-c4p8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41283

Advisory: OpenStack Mistral allows Arbitrary Remote Code Execution when the API is exposed
IDs: CVE-2026-41283, GHSA-9hfw-w3f4-c4p8
Record: https://patchnext.com/advisories/cve-2026-41283 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: mistral 20.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mistral: affected >= 20.0.0, < 20.1.1; >= 21.0.0, <= 21.0.0; >= 22.0.0, <= 22.0.0; fixed in 20.1.1

## Suggested inspection (read-only)
- `python -m pip show mistral`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mistral.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9hfw-w3f4-c4p8 (GitHub-reviewed advisory GHSA-9hfw-w3f4-c4p8 lists affected ranges: PyPI mistral >=20.0.0 =21.0.0 =22.0.0 <=22.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-9hfw-w3f4-c4p8 (OSV record GHSA-9hfw-w3f4-c4p8 lists affected ranges: PyPI mistral >=20.0.0 <20.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…