Skip to content

← Actionable
High, CVSS 8.2amended

Flowise: Unauthenticated TTS endpoint accepts arbitrary credential IDs — enables API credit abuse via stored credentials

CVE-2026-41279GHSA-5fw2-mwhh-9947

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.0.13
    Fixed in
    3.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41279: 0.26% estimated exploitation activity in the next 30 days; percentile 17.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The text-to-speech generation endpoint (POST /api/v1/text-to-speech/generate) is whitelisted (no auth) and accepts a credentialId directly in the request body. When called without a chatflowId, the endpoint uses the provided credentialId to decrypt the stored credential (e.g., OpenAI or ElevenLabs API key) and generate speech. Root Cause Docker Validation POST /api/v1/text-to-speech/generate with arbitrary credentialId in body: endpoint processes request, sends SSE ttsstart event, only fails when credential doesn't exist — proves code path runs without authentication. Impact - Use victim's API keys (OpenAI, ElevenLabs, Azure, Google) without authorization - Burn API credits on the victim's account - Generate unlimited speech content at victim's expense - Combined with credential ID leak from Finding 2, this is trivially exploitable Suggested Fix Remove the TTS endpoint from WHITELISTURLS or validate that the credential belongs to the chatflow being used: --- References -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5fw2-mwhh-9947

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5fw2-mwhh-9947

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41279

Advisory: Flowise: Unauthenticated TTS endpoint accepts arbitrary credential IDs — enables API credit abuse via stored credentials
IDs: CVE-2026-41279, GHSA-5fw2-mwhh-9947
Record: https://patchnext.com/advisories/cve-2026-41279 (revision 3, source checked 26 Oct 2026, 12:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.0.13; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5fw2-mwhh-9947 (OSV record GHSA-5fw2-mwhh-9947 lists affected ranges: npm flowise >=0 <3.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5fw2-mwhh-9947 (GitHub-reviewed advisory GHSA-5fw2-mwhh-9947 lists affected ranges: npm flowise >=0 <=3.0.13)

Commands are suggestions: review each one before running it.

Loading voting…