Flowise: resetPassword Authentication Bypass Vulnerability
CVE-2026-41276GHSA-f6hc-c5jr-878p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm flowise
- Affected
- <= 3.0.13
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f6hc-c5jr-878p lists affected ranges: npm flowise >=0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f6hc-c5jr-878p lists affected ranges: npm flowise >=0 <=3.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-41276: 6.87% estimated exploitation activity in the next 30 days; percentile 94.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ZDI-CAN-28762: Flowise AccountService resetPassword Authentication Bypass Vulnerability -- ABSTRACT ------------------------------------- Trend Micro's Zero Day Initiative has identified a vulnerability affecting the following products: Flowise - Flowise -- VULNERABILITY DETAILS ------------------------ Version tested: 3.0.12 Installer file: hxxps://github.com/FlowiseAI/Flowise Platform tested: NA --- Analysis This vulnerability allows remote attackers to bypass authentication on affected installations of FlowiseAI Flowise. Authentication is not required to exploit this vulnerability. The specific flaw exists within the resetPassword method of the AccountService class. The issue results from improper implementation of the authentication mechanism. An attacker can leverage this vulnerability to change user's passwords and bypass authentication on the system. Product information FlowiseAI Flowise version 3.0.12 (hxxps://github.com/FlowiseAI/Flowise) Setup Instructions Root Cause…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f6hc-c5jr-878p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f6hc-c5jr-878p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41276 Advisory: Flowise: resetPassword Authentication Bypass Vulnerability IDs: CVE-2026-41276, GHSA-f6hc-c5jr-878p Record: https://patchnext.com/advisories/cve-2026-41276 (revision 3, source checked 26 Oct 2026, 12:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise: affected <= 3.0.13; fixed in 3.1.0 ## Suggested inspection (read-only) - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f6hc-c5jr-878p (OSV record GHSA-f6hc-c5jr-878p lists affected ranges: npm flowise >=0 <3.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-f6hc-c5jr-878p (GitHub-reviewed advisory GHSA-f6hc-c5jr-878p lists affected ranges: npm flowise >=0 <=3.0.13) Commands are suggestions: review each one before running it.
Loading voting…