Skip to content

← Actionable
High, CVSS 7.5amended

Flowise: Password Reset Link Sent Over Unsecured HTTP

CVE-2026-41275GHSA-x5w6-38gp-mrqh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.0.13
    Fixed in
    3.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41275: 0.18% estimated exploitation activity in the next 30 days; percentile 7.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary: The password reset functionality on cloud.flowiseai.com sends a reset password link over the unsecured HTTP protocol instead of HTTPS. This behavior introduces the risk of a man-in-the-middle (MITM) attack, where an attacker on the same network as the user (e.g., public Wi-Fi) can intercept the reset link and gain unauthorized access to the victim’s account. Steps to Reproduce: 1. Sign up for a new account on https://cloud.flowiseai.com/register. 2. Navigate to the https://cloud.flowiseai.com/forgot-password page and enter your email. 3. Open your inbox and locate the password reset email. 4. Copy the reset link and inspect its protocol – it uses http:// instead of https://. POC:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x5w6-38gp-mrqh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x5w6-38gp-mrqh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41275

Advisory: Flowise: Password Reset Link Sent Over Unsecured HTTP
IDs: CVE-2026-41275, GHSA-x5w6-38gp-mrqh
Record: https://patchnext.com/advisories/cve-2026-41275 (revision 3, source checked 26 Oct 2026, 12:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.0.13; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x5w6-38gp-mrqh (OSV record GHSA-x5w6-38gp-mrqh lists affected ranges: npm flowise >=0 <3.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x5w6-38gp-mrqh (GitHub-reviewed advisory GHSA-x5w6-38gp-mrqh lists affected ranges: npm flowise >=0 <=3.0.13)

Commands are suggestions: review each one before running it.

Loading voting…