Skip to content

← Actionable
High, CVSS 8.1amended

Flowise: Improper Mass Assignment in Account Registration Enables Unauthorized Organization Association

CVE-2026-41267GHSA-48m6-ch88-55mj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.0.13
    Fixed in
    3.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41267: 0.33% estimated exploitation activity in the next 30 days; percentile 26.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An improper mass assignment (JSON injection) vulnerability in the account registration endpoint of Flowise Cloud allows unauthenticated attackers to inject server-managed fields and nested objects during account creation. This enables client-controlled manipulation of ownership metadata, timestamps, organization association, and role mappings, breaking trust boundaries in a multi-tenant environment. Details The POST /api/v1/account/register endpoint is intended to accept a minimal payload to create a new user account (e.g., name, email, password). However, the backend fails to enforce a strict allowlist or DTO-based validation and instead blindly maps client-supplied JSON to internal domain models. As a result, attackers can include additional nested objects and server-managed fields in the request body such as organization, organizationUser, workspace, workspaceUser, and metadata fields like createdBy, updatedBy, createdDate, and updatedDate. These fields are persisted as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-48m6-ch88-55mj

  2. Revision 1 · created ·

    Published from osv record GHSA-48m6-ch88-55mj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41267

Advisory: Flowise: Improper Mass Assignment in Account Registration Enables Unauthorized Organization Association
IDs: CVE-2026-41267, GHSA-48m6-ch88-55mj
Record: https://patchnext.com/advisories/cve-2026-41267 (revision 2, source checked 26 Oct 2026, 12:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.0.13; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-48m6-ch88-55mj (OSV record GHSA-48m6-ch88-55mj lists affected ranges: npm flowise >=0 <3.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-48m6-ch88-55mj (GitHub-reviewed advisory GHSA-48m6-ch88-55mj lists affected ranges: npm flowise >=0 <=3.0.13)

Commands are suggestions: review each one before running it.

Loading voting…