CKAN has CSRF exemption primed by anonymous requests
CVE-2026-41255GHSA-mcvf-jxcw-vj73
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckan 2.11.5, 2.10.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ckan
- Affected
- >= 2.10.0, < 2.10.10>= 2.11.0, <= 2.11.4
- Fixed in
- 2.11.5, 2.10.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mcvf-jxcw-vj73 lists affected ranges: PyPI ckan >=2.10.0 =2.11.0 <2.11.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mcvf-jxcw-vj73 lists affected ranges: PyPI ckan >=2.10.0 =2.11.0 <=2.11.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-41255: 0.12% estimated exploitation activity in the next 30 days; percentile 2.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Views can be marked as exempt from CSRF protection Access to the views via tokens or unauthenticated requests marked the endpoint as not requiring CSRF protection. The marking was a member variable in flask-wtf.csrf.CSRFProtect(), which was stored as a module level variable in the flaskapp middleware. Thsi API was never intended for request level changes, it is primarily a decorator for static configuration. An unauthenticated request could hit a protected endpoint, exempting it from CSRF protection for the life of the particular server process. (e.g. one worker of uwsgi). This could be leveraged with XSS to perform actions using other user's credentials. References Vulnerability report by @Shirshaw64p (original reporter)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mcvf-jxcw-vj73
- Revision 1 · created ·
Published from osv record GHSA-mcvf-jxcw-vj73
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41255 Advisory: CKAN has CSRF exemption primed by anonymous requests IDs: CVE-2026-41255, GHSA-mcvf-jxcw-vj73 Record: https://patchnext.com/advisories/cve-2026-41255 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckan 2.11.5, 2.10.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ckan: affected >= 2.10.0, < 2.10.10; >= 2.11.0, <= 2.11.4; fixed in 2.11.5, 2.10.10 ## Suggested inspection (read-only) - `python -m pip show ckan`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckan. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mcvf-jxcw-vj73 (OSV record GHSA-mcvf-jxcw-vj73 lists affected ranges: PyPI ckan >=2.10.0 =2.11.0 <2.11.5 (fixed)) - Verified: https://github.com/advisories/GHSA-mcvf-jxcw-vj73 (GitHub-reviewed advisory GHSA-mcvf-jxcw-vj73 lists affected ranges: PyPI ckan >=2.10.0 =2.11.0 <=2.11.4) Commands are suggestions: review each one before running it.
Loading voting…