elFinder: Command injection in resize background color parameter when using ImageMagick CLI
CVE-2026-41247GHSA-8q4h-8crm-5cvc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (studio-42/elfinder 2.1.67), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist studio-42/elfinder
- Affected
- < 2.1.67
- Fixed in
- 2.1.67
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8q4h-8crm-5cvc lists affected ranges: Packagist studio-42/elfinder >=0 <2.1.67
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-41247: 1.57% estimated exploitation activity in the next 30 days; percentile 75.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Severity High bg can be injected into shell command construction, leading to possible RCE in affected configurations. Summary elFinder contains a command injection vulnerability in the resize command. The bg (background color) parameter is accepted from user input and passed through image resize/rotate processing. In configurations that use the ImageMagick CLI backend, this value is incorporated into shell command strings without sufficient escaping. An attacker able to invoke the resize command with a crafted bg value may achieve arbitrary command execution as the web server process user. This issue affects configurations where: - the resize command is enabled, - image processing uses the ImageMagick CLI backend, and - the vulnerable code paths are reachable. Impact An attacker may execute arbitrary OS commands with the privileges of the web server process. Impact depends on server configuration, enabled commands, backend image library selection, and surrounding deployment controls.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8q4h-8crm-5cvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41247 Advisory: elFinder: Command injection in resize background color parameter when using ImageMagick CLI IDs: CVE-2026-41247, GHSA-8q4h-8crm-5cvc Record: https://patchnext.com/advisories/cve-2026-41247 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: studio-42/elfinder 2.1.67. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist studio-42/elfinder: affected < 2.1.67; fixed in 2.1.67 ## Suggested inspection (read-only) - Packagist studio-42/elfinder: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on studio-42/elfinder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8q4h-8crm-5cvc (GitHub-reviewed advisory GHSA-8q4h-8crm-5cvc lists affected ranges: Packagist studio-42/elfinder >=0 <2.1.67) Commands are suggestions: review each one before running it.
Loading voting…